[Domanda] tutorial server 1.7.x 1.13.x

raga, ho un server da 32gb su una vps,
modalitá e bungeecord in un’unica vps, non saprei quale bungeecord installare e quale versione di spigot nei miei server da installare e che plugins mettere per rendere compatibile il server dalla 1.7 alla 1.13, anche 1.8-1.13 va bene.. nelle config del bungee ho messo come host: l’ipdellamacchina:25565, i server in localhost:porta, e nel server.properties dovrei mettere 127.0.0.1?
27/07/2018, 22:11zAndreHD ha scritto: raga, ho un server da 32gb su una vps,
modalitá e bungeecord in un’unica vps, non saprei quale bungeecord installare e quale versione di spigot nei miei server da installare e che plugins mettere per rendere compatibile il server dalla 1.7 alla 1.13, anche 1.8-1.13 va bene.. nelle config del bungee ho messo come host: l’ipdellamacchina:25565, i server in localhost:porta, e nel server.properties dovrei mettere 127.0.0.1?

Ti consiglierei di fare il server da 1.8.x a 1.13 e per fare ciò devi utilizzare sempre l'ultima versione di bungeecord(per questioni di sicurezza).
la scelta della versione di spigot non è casuale, bisogna utilizzare la versione più bassa, in questo caso dovrai usare "spigot-1.8.8.jar" e utilizzare il plugin "ViaVersion" il quale renderà il server accessibile fino all'utlima versione(sempre se gli sviluppatori hanno rilasciato l'aggiornamento per la 1.13) .

volendo si può fare anche il procedimento inverso, ovvero creare un server 1.13 e renderlo utilizzabile fino alla 1.8.X utilizzando "ViaBackwards" oppure "protocolsupport" (anche qui sempre se gli sviluppatori hanno rilasciato il supporto per la 1.13), ma te lo sconsiglio in quanto la build di spigot-1.13 al momento non è consigliata per dei server pubblici, e inoltre ci sono pochi plugin aggiornati per i server in 1.13 (Modificato 28/07/2018, 15:19 da Legends.)
Ti sono stato di aiuto? Clicca sul tasto "+1" in basso a sinistra ! Smile
28/07/2018, 15:13Legends ha scritto:
27/07/2018, 22:11zAndreHD ha scritto: raga, ho un server da 32gb su una vps,
modalitá e bungeecord in un’unica vps, non saprei quale bungeecord installare e quale versione di spigot nei miei server da installare e che plugins mettere per rendere compatibile il server dalla 1.7 alla 1.13, anche 1.8-1.13 va bene.. nelle config del bungee ho messo come host: l’ipdellamacchina:25565, i server in localhost:porta, e nel server.properties dovrei mettere 127.0.0.1?

Ti consiglierei di fare il server da 1.8.x a 1.13 e per fare ciò devi utilizzare sempre l'ultima versione di bungeecord(per questioni di sicurezza).
la scelta della versione di spigot non è casuale, bisogna utilizzare la versione più bassa, in questo caso dovrai usare "spigot-1.8.8.jar" e utilizzare il plugin "ViaVersion" il quale renderà il server accessibile fino all'utlima versione(sempre se gli sviluppatori hanno rilasciato l'aggiornamento per la 1.13) .

volendo si può fare anche il procedimento inverso, ovvero creare un server 1.13 e renderlo utilizzabile fino alla 1.8.X utilizzando "ViaBackwards" oppure "protocolsupport" (anche qui sempre se gli sviluppatori hanno rilasciato il supporto per la 1.13), ma te lo sconsiglio in quanto la build di spigot-1.13 al momento non è consigliata per dei server pubblici, e inoltre ci sono pochi plugin aggiornati per i server in 1.13
Ho usato una versione di HexagonMC(Bungeecord) il quale lo rende accessibile da 1.7 a 1.12.. poi, nei vari servers, c’ho messo protocolsupport e viaversion insieme.. ma essendo la versione di spigot 1.12.2, viaversion non è compatibile con protocolsupport con appunto versioni di spigot da 1.12 in su.. ecco perché viaversion l’ho messo nel bungeecord.. la 1.13 funziona nella lobby e nel practice, ma nel factions no, nonostante sia un server bungee.. e quando starto il vanilla 1.13(accessibile appunto solo con 1.13) mi dice: bad packet unsupported protocol version( posso uppare il messaggio se vuoi)

https://prnt.sc/kc5qg7 (Modificato 28/07/2018, 18:03 da zAndreHD.)
28/07/2018, 18:00zAndreHD ha scritto:
28/07/2018, 15:13Legends ha scritto:
27/07/2018, 22:11zAndreHD ha scritto: raga, ho un server da 32gb su una vps,
modalitá e bungeecord in un’unica vps, non saprei quale bungeecord installare e quale versione di spigot nei miei server da installare e che plugins mettere per rendere compatibile il server dalla 1.7 alla 1.13, anche 1.8-1.13 va bene.. nelle config del bungee ho messo come host: l’ipdellamacchina:25565, i server in localhost:porta, e nel server.properties dovrei mettere 127.0.0.1?

Ti consiglierei di fare il server da 1.8.x a 1.13 e per fare ciò devi utilizzare sempre l'ultima versione di bungeecord(per questioni di sicurezza).
la scelta della versione di spigot non è casuale, bisogna utilizzare la versione più bassa, in questo caso dovrai usare "spigot-1.8.8.jar" e utilizzare il plugin "ViaVersion" il quale renderà il server accessibile fino all'utlima versione(sempre se gli sviluppatori hanno rilasciato l'aggiornamento per la 1.13) .

volendo si può fare anche il procedimento inverso, ovvero creare un server 1.13 e renderlo utilizzabile fino alla 1.8.X utilizzando "ViaBackwards" oppure "protocolsupport" (anche qui sempre se gli sviluppatori hanno rilasciato il supporto per la 1.13), ma te lo sconsiglio in quanto la build di spigot-1.13 al momento non è consigliata per dei server pubblici, e inoltre ci sono pochi plugin aggiornati per i server in 1.13
Ho usato una versione di HexagonMC(Bungeecord) il quale lo rende accessibile da 1.7 a 1.12.. poi, nei vari servers, c’ho messo protocolsupport e viaversion insieme.. ma essendo la versione di spigot 1.12.2, viaversion non è compatibile con protocolsupport con appunto versioni di spigot da 1.12 in su.. ecco perché viaversion l’ho messo nel bungeecord.. la 1.13 funziona nella lobby e nel practice, ma nel factions no, nonostante sia un server bungee.. e quando starto il vanilla 1.13(accessibile appunto solo con 1.13) mi dice: bad packet unsupported protocol version( posso uppare il messaggio se vuoi)

https://prnt.sc/kc5qg7
protocolsupport non è stato aggiornato per la 1.13, quindi credo che sia questa la causa
Ti sono stato di aiuto? Clicca sul tasto "+1" in basso a sinistra ! Smile
1 utente apprezza questo post
‘ma ho viaversion nel bungee.. infatti la lobby e il practice vanno mentre il factions non so perché ma nk
Discussioni simili
 
[Problema] spigot 1.13
4 231
Risposta di xGab0
12/10/2018, 18:10
Risposta di zTronic
25/07/2018, 14:03
 
2 295
Risposta di Maxetto
24/07/2018, 12:02
Risposta di Ravenner
23/07/2018, 19:44
Risposta di NoHaxJustHD
12/06/2018, 22:58

Utente(i) che stanno guardando questa discussione: 1 Ospite(i)