Eclipse mi fa scherzi

Oggi stavo facendo un plugin e nel bel mezzo della programmazione al mio main mi succede questo:
[Immagine: 0226aa28262cae53f27a01c4810d70f5.jpg]
Qualcuno sa come risolverlo?


Inviato dal mio LG-D320 utilizzando Tapatalk
Potresti farci vedere gli import e cosa hai per le librerie e javadoc?
Una cosa così non mi è mai capitata.

Comunque prova a fare F5 oppure Save All, magari ti risolve il problema. (Modificato 28/06/2015, 15:02 da Nickframe76.)
Se ti sono stato utile pigia quel bel pulsantino REP.

KINGS OF THE HILLS
[Immagine: xwUIc7j.jpg]


[Immagine: Renzi.jpg]
RENZI COMANDERA' IL MONDO UN GIORNO!
@NickFrame67 nelle librerie ho spigot e java per appunto creare plugin, ho fatto save all ma spunta lo stesso errore

Inviato dal mio LG-D320 utilizzando Tapatalk
@IcarusFox, dammi gli import, dove hai preso lo spigot.jar? L'hai compilato con build tools? E poi quali JavaDoc hai?

Edit: In Java, per convenzione tutte le classi iniziano per lettera maiuscola, prova a cambiargli il nome, magari riesci a risolvere. (Modificato 28/06/2015, 15:30 da Nickframe76.)
Se ti sono stato utile pigia quel bel pulsantino REP.

KINGS OF THE HILLS
[Immagine: xwUIc7j.jpg]


[Immagine: Renzi.jpg]
RENZI COMANDERA' IL MONDO UN GIORNO!
Lo spigot l'ho preso da spigotdl.com per il resto ora ti invio una foto

Inviato dal mio LG-D320 utilizzando Tapatalk
[Immagine: 6c3b6b3c2d259180b39f9b593e12bf97.jpg]

[Immagine: cdd96780f8c9557450011d0424360578.jpg] (Modificato 28/06/2015, 15:32 da IcarusFox.)
Perché l'onEnable è una Boolean?
Deve essere un void come la sua controparte onDisable.
Ricordati di mettere la "M" maiuscola sulla classe Main.
Se ti sono stato utile pigia quel bel pulsantino REP.

KINGS OF THE HILLS
[Immagine: xwUIc7j.jpg]


[Immagine: Renzi.jpg]
RENZI COMANDERA' IL MONDO UN GIORNO!
Lo so sto controllando alcune cose.
Ma cosa cambia tra Main e main?

Inviato dal mio LG-D320 utilizzando Tapatalk
Il nome fa differenza, anche se è una convenzione, ho avuto un problema simile e l'ho fixato mettendo il nome maiuscolo sulle classi.
Se ti sono stato utile pigia quel bel pulsantino REP.

KINGS OF THE HILLS
[Immagine: xwUIc7j.jpg]


[Immagine: Renzi.jpg]
RENZI COMANDERA' IL MONDO UN GIORNO!
Ok appena ho il pc libero lo modifico immediatament e ti faccio sapere se da ancora l'errore

Inviato dal mio LG-D320 utilizzando Tapatalk
Discussioni simili
Discussione: Autore Risposte: Letto: Ultimo
[Problema] Eclipse MCgamer99 5 273 29/06/2017, 01:56
Ultimo: ReahLyy
[Domanda] Qualcuno esperto in java mi puo spiegare passo per passo cosa fa questo codice?? guani2000 6 402 21/06/2017, 13:14
Ultimo: FreedeX
[Risolto] Plugins con eclipse playton_ 4 274 09/03/2017, 22:27
Ultimo: _gjkf_
non mi trova gli import su CentOS 6 64 bit KillerVillager 2 242 28/01/2017, 14:32
Ultimo: KillerVillager
[Problema] Non mi carica un plugin.. DBenQ 22 932 09/01/2017, 18:58
Ultimo: DeeJack

Utente(i) che stanno guardando questa discussione: 1 Ospite(i)