[Launcher] Problemi nel launcher di Minecraft per la 1.8.x

Buongiorno a tutti.
Volevo chiedere un aiuto riguardo a questo problema un po' ambiguo di Minecraft.
Avevo voglia di provare una nuova modalità di un Server ed ho scoperto che, per giocarvi, bisognava avere la versione 1.8. Allora ho installato la OptiFine (come faccio di solito) per la versione 1.8, ho cliccato "Play" e appare il messaggio "Si è verificato un problema imprevisto e il gioco si è arrestato in modo anomalo. Ci scusiamo per il disagio."
Ho provato e riprovato a cliccare nuovamente "Play" o provare altre versioni della 1.8 (1.8.1, 1.8.2 ecc...), ma appare sempre lo stesso problema.
Qualcuno sa quale possa essere il problema?
Vi ringrazio in anticipo!
07/08/2018, 09:43TommyWorld68 ha scritto: Buongiorno a tutti.
Volevo chiedere un aiuto riguardo a questo problema un po' ambiguo di Minecraft.
Avevo voglia di provare una nuova modalità di un Server ed ho scoperto che, per giocarvi, bisognava avere la versione 1.8. Allora ho installato la OptiFine (come faccio di solito) per la versione 1.8, ho cliccato "Play" e appare il messaggio "Si è verificato un problema imprevisto e il gioco si è arrestato in modo anomalo. Ci scusiamo per il disagio."
Ho provato e riprovato a cliccare nuovamente "Play" o provare altre versioni della 1.8 (1.8.1, 1.8.2 ecc...), ma appare sempre lo stesso problema.
Qualcuno sa quale possa essere il problema?
Vi ringrazio in anticipo!

Mandaci il crash log lo trovi nel .minecraft (il più recente)
@TommyWorld68
Sempre disponibile e al vostro servizio!
Se vi sono stato d'aiuto ricordatevi di lasciare un like 
 e un rep cliccando sul +1 a sinistra!
Telegram: @GabrieleMc
1 utente apprezza questo post
[10:45:40] [main/INFO]: Loading tweak class name optifine.OptiFineTweaker
[10:45:40] [main/INFO]: Using primary tweak class name optifine.OptiFineTweaker
[10:45:40] [main/INFO]: Calling tweak class optifine.OptiFineTweaker
[10:45:40] [main/INFO]: Launching wrapped minecraft {net.minecraft.client.main.Main}
[10:45:40] [Client thread/INFO]: Setting user: TommyWorld68
[10:45:40] [Client thread/INFO]: (Session ID is token:befa193a166e4f14b792a4d45e36e2af:ac349cc13716425380b36c29b8b5b74a)
[10:45:40] [Client thread/ERROR]: Unable to launch
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_51]
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_51]
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_51]
at java.lang.reflect.Method.invoke(Method.java:497) ~[?:1.8.0_51]
at net.minecraft.launchwrapper.Launch.launch(Launch.java:135) [launchwrapper-1.12.jar:?]
at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.12.jar:?]
Caused by: com.google.gson.JsonSyntaxException: java.lang.IllegalStateException: Expected BEGIN_ARRAY but was STRING at line 1 column 1
at com.google.gson.Gson.fromJson(Gson.java:815) ~[Gson.class:?]
at com.google.gson.Gson.fromJson(Gson.java:768) ~[Gson.class:?]
at ry.b(SourceFile:148) ~[ry.class:?]
at ry.<init>(SourceFile:42) ~[ry.class:?]
at net.minecraft.server.MinecraftServer.<init>(SourceFile:155) ~[MinecraftServer.class:?]
at cyk.<init>(IntegratedServer.java:51) ~[cyk.class:?]
at bsu.<init>(SourceFile:282) ~[bsu.class:?]
at net.minecraft.client.main.Main.main(SourceFile:120) ~[Main.class:?]
... 6 more
Caused by: java.lang.IllegalStateException: Expected BEGIN_ARRAY but was STRING at line 1 column 1
at com.google.gson.stream.JsonReader.beginArray(JsonReader.java:338) ~[JsonReader.class:?]
at com.google.gson.internal.bind.CollectionTypeAdapterFactory$Adapter.read(CollectionTypeAdapterFactory.java:79) ~[CollectionTypeAdapterFactory$Adapter.class:?]
at com.google.gson.internal.bind.CollectionTypeAdapterFactory$Adapter.read(CollectionTypeAdapterFactory.java:60) ~[CollectionTypeAdapterFactory$Adapter.class:?]
at com.google.gson.Gson.fromJson(Gson.java:803) ~[Gson.class:?]
at com.google.gson.Gson.fromJson(Gson.java:768) ~[Gson.class:?]
at ry.b(SourceFile:148) ~[ry.class:?]
at ry.<init>(SourceFile:42) ~[ry.class:?]
at net.minecraft.server.MinecraftServer.<init>(SourceFile:155) ~[MinecraftServer.class:?]
at cyk.<init>(IntegratedServer.java:51) ~[cyk.class:?]
at bsu.<init>(SourceFile:282) ~[bsu.class:?]
at net.minecraft.client.main.Main.main(SourceFile:120) ~[Main.class:?]
... 6 more



(PS: spero sia quello giusto. Sono un po' ignorante in informatica)

Se entro in Minecraft con la 1.9.x o versioni superiori funziona, è solo con la 1.8.x che dà problemi.
Se magari vi servono altri dati... chiedete pure
@Gabri19 (Modificato 07/08/2018, 10:03 da TommyWorld68.)
07/08/2018, 09:53TommyWorld68 ha scritto: [10:45:40] [main/INFO]: Loading tweak class name optifine.OptiFineTweaker
[10:45:40] [main/INFO]: Using primary tweak class name optifine.OptiFineTweaker
[10:45:40] [main/INFO]: Calling tweak class optifine.OptiFineTweaker
[10:45:40] [main/INFO]: Launching wrapped minecraft {net.minecraft.client.main.Main}
[10:45:40] [Client thread/INFO]: Setting user: TommyWorld68
[10:45:40] [Client thread/INFO]: (Session ID is token:befa193a166e4f14b792a4d45e36e2af:ac349cc13716425380b36c29b8b5b74a)
[10:45:40] [Client thread/ERROR]: Unable to launch
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_51]
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_51]
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_51]
at java.lang.reflect.Method.invoke(Method.java:497) ~[?:1.8.0_51]
at net.minecraft.launchwrapper.Launch.launch(Launch.java:135) [launchwrapper-1.12.jar:?]
at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.12.jar:?]
Caused by: com.google.gson.JsonSyntaxException: java.lang.IllegalStateException: Expected BEGIN_ARRAY but was STRING at line 1 column 1
at com.google.gson.Gson.fromJson(Gson.java:815) ~[Gson.class:?]
at com.google.gson.Gson.fromJson(Gson.java:768) ~[Gson.class:?]
at ry.b(SourceFile:148) ~[ry.class:?]
at ry.<init>(SourceFile:42) ~[ry.class:?]
at net.minecraft.server.MinecraftServer.<init>(SourceFile:155) ~[MinecraftServer.class:?]
at cyk.<init>(IntegratedServer.java:51) ~[cyk.class:?]
at bsu.<init>(SourceFile:282) ~[bsu.class:?]
at net.minecraft.client.main.Main.main(SourceFile:120) ~[Main.class:?]
... 6 more
Caused by: java.lang.IllegalStateException: Expected BEGIN_ARRAY but was STRING at line 1 column 1
at com.google.gson.stream.JsonReader.beginArray(JsonReader.java:338) ~[JsonReader.class:?]
at com.google.gson.internal.bind.CollectionTypeAdapterFactory$Adapter.read(CollectionTypeAdapterFactory.java:79) ~[CollectionTypeAdapterFactory$Adapter.class:?]
at com.google.gson.internal.bind.CollectionTypeAdapterFactory$Adapter.read(CollectionTypeAdapterFactory.java:60) ~[CollectionTypeAdapterFactory$Adapter.class:?]
at com.google.gson.Gson.fromJson(Gson.java:803) ~[Gson.class:?]
at com.google.gson.Gson.fromJson(Gson.java:768) ~[Gson.class:?]
at ry.b(SourceFile:148) ~[ry.class:?]
at ry.<init>(SourceFile:42) ~[ry.class:?]
at net.minecraft.server.MinecraftServer.<init>(SourceFile:155) ~[MinecraftServer.class:?]
at cyk.<init>(IntegratedServer.java:51) ~[cyk.class:?]
at bsu.<init>(SourceFile:282) ~[bsu.class:?]
at net.minecraft.client.main.Main.main(SourceFile:120) ~[Main.class:?]
... 6 more



(PS: spero sia quello giusto. Sono un po' ignorante in informatica)

Se entro in Minecraft con la 1.9.x o versioni superiori funziona, è solo con la 1.8.x che dà problemi.
Se magari vi servono altri dati... chiedete pure
@Gabri19

Spiegami cosa hai fatto.. Hai installato la optifine in 1.8 e dopo averla installata non ti va più? @TommyWorld68
Sempre disponibile e al vostro servizio!
Se vi sono stato d'aiuto ricordatevi di lasciare un like 
 e un rep cliccando sul +1 a sinistra!
Telegram: @GabrieleMc
07/08/2018, 10:19Gabri19 ha scritto:
07/08/2018, 09:53TommyWorld68 ha scritto: [10:45:40] [main/INFO]: Loading tweak class name optifine.OptiFineTweaker
[10:45:40] [main/INFO]: Using primary tweak class name optifine.OptiFineTweaker
[10:45:40] [main/INFO]: Calling tweak class optifine.OptiFineTweaker
[10:45:40] [main/INFO]: Launching wrapped minecraft {net.minecraft.client.main.Main}
[10:45:40] [Client thread/INFO]: Setting user: TommyWorld68
[10:45:40] [Client thread/INFO]: (Session ID is token:befa193a166e4f14b792a4d45e36e2af:ac349cc13716425380b36c29b8b5b74a)
[10:45:40] [Client thread/ERROR]: Unable to launch
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_51]
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) ~[?:1.8.0_51]
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_51]
at java.lang.reflect.Method.invoke(Method.java:497) ~[?:1.8.0_51]
at net.minecraft.launchwrapper.Launch.launch(Launch.java:135) [launchwrapper-1.12.jar:?]
at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.12.jar:?]
Caused by: com.google.gson.JsonSyntaxException: java.lang.IllegalStateException: Expected BEGIN_ARRAY but was STRING at line 1 column 1
at com.google.gson.Gson.fromJson(Gson.java:815) ~[Gson.class:?]
at com.google.gson.Gson.fromJson(Gson.java:768) ~[Gson.class:?]
at ry.b(SourceFile:148) ~[ry.class:?]
at ry.<init>(SourceFile:42) ~[ry.class:?]
at net.minecraft.server.MinecraftServer.<init>(SourceFile:155) ~[MinecraftServer.class:?]
at cyk.<init>(IntegratedServer.java:51) ~[cyk.class:?]
at bsu.<init>(SourceFile:282) ~[bsu.class:?]
at net.minecraft.client.main.Main.main(SourceFile:120) ~[Main.class:?]
... 6 more
Caused by: java.lang.IllegalStateException: Expected BEGIN_ARRAY but was STRING at line 1 column 1
at com.google.gson.stream.JsonReader.beginArray(JsonReader.java:338) ~[JsonReader.class:?]
at com.google.gson.internal.bind.CollectionTypeAdapterFactory$Adapter.read(CollectionTypeAdapterFactory.java:79) ~[CollectionTypeAdapterFactory$Adapter.class:?]
at com.google.gson.internal.bind.CollectionTypeAdapterFactory$Adapter.read(CollectionTypeAdapterFactory.java:60) ~[CollectionTypeAdapterFactory$Adapter.class:?]
at com.google.gson.Gson.fromJson(Gson.java:803) ~[Gson.class:?]
at com.google.gson.Gson.fromJson(Gson.java:768) ~[Gson.class:?]
at ry.b(SourceFile:148) ~[ry.class:?]
at ry.<init>(SourceFile:42) ~[ry.class:?]
at net.minecraft.server.MinecraftServer.<init>(SourceFile:155) ~[MinecraftServer.class:?]
at cyk.<init>(IntegratedServer.java:51) ~[cyk.class:?]
at bsu.<init>(SourceFile:282) ~[bsu.class:?]
at net.minecraft.client.main.Main.main(SourceFile:120) ~[Main.class:?]
... 6 more



(PS: spero sia quello giusto. Sono un po' ignorante in informatica)

Se entro in Minecraft con la 1.9.x o versioni superiori funziona, è solo con la 1.8.x che dà problemi.
Se magari vi servono altri dati... chiedete pure
@Gabri19

Spiegami cosa hai fatto.. Hai installato la optifine in 1.8 e dopo averla installata non ti va più? @TommyWorld68
Io dovevo entrare nella 1.8 e, come al solito, ho scaricato la OptiFine.
Però la OptiFine si è installata correttamente come sempre! Non penso sia quello il problema.
Ho provato anche ad entrare nelle versioni della 1.8 senza OptiFine, ma il problema persiste nuovamente.

Penso che sia proprio le versioni della 1.8.x che creano questi "crash"... perchè con le altre versioni, ribadisco, tutto procede normalmente!
@Gabri19
07/08/2018, 10:23TommyWorld68 ha scritto: Io dovevo entrare nella 1.8 e, come al solito, ho scaricato la OptiFine.
Però la OptiFine si è installata correttamente come sempre! Non penso sia quello il problema.
Ho provato anche ad entrare nelle versioni della 1.8 senza OptiFine, ma il problema persiste nuovamente.

Penso che sia proprio le versioni della 1.8.x che creano questi "crash"... perchè con le altre versioni, ribadisco, tutto procede normalmente!
@Gabri19

Prova a cancellare i file della 1.8 e poi dal launcher riscaricarli @TommyWorld68
Sempre disponibile e al vostro servizio!
Se vi sono stato d'aiuto ricordatevi di lasciare un like 
 e un rep cliccando sul +1 a sinistra!
Telegram: @GabrieleMc
Chiedo scusa, ma sono davvero un "noob" in informatica.
Quali sono i file della 1.8?
@Gabri19
07/08/2018, 10:32TommyWorld68 ha scritto: Chiedo scusa, ma sono davvero un "noob" in informatica.
Quali sono i file della 1.8?
@Gabri19

Allora apri Start e cerca %appdata%, apri il .minecraft e vai nella cartella versions, li dentro elimina tutte le cartelle della 1.8. Poi apri il launcher vai nelle opzioni di avvio clicca sulla 1.8 e eliminala. Una volta fatto selezioni "Nuova opzione di avvio" e inserisci la versione @TommyWorld68
Sempre disponibile e al vostro servizio!
Se vi sono stato d'aiuto ricordatevi di lasciare un like 
 e un rep cliccando sul +1 a sinistra!
Telegram: @GabrieleMc
07/08/2018, 10:44Gabri19 ha scritto:
07/08/2018, 10:32TommyWorld68 ha scritto: Chiedo scusa, ma sono davvero un "noob" in informatica.
Quali sono i file della 1.8?
@Gabri19

Allora apri Start e cerca %appdata%, apri il .minecraft e vai nella cartella versions, li dentro elimina tutte le cartelle della 1.8. Poi apri il launcher vai nelle opzioni di avvio clicca sulla 1.8 e eliminala. Una volta fatto selezioni "Nuova opzione di avvio" e inserisci la versione @TommyWorld68


Niente, sempre la stessa schermata.... ho rifatto il procedimento che mi hai detto più volte, ma niente.
Ti ringrazio comunque per il tempo @Gabri19
07/08/2018, 10:47TommyWorld68 ha scritto:
07/08/2018, 10:44Gabri19 ha scritto:
07/08/2018, 10:32TommyWorld68 ha scritto: Chiedo scusa, ma sono davvero un "noob" in informatica.
Quali sono i file della 1.8?
@Gabri19

Allora apri Start e cerca %appdata%, apri il .minecraft e vai nella cartella versions, li dentro elimina tutte le cartelle della 1.8. Poi apri il launcher vai nelle opzioni di avvio clicca sulla 1.8 e eliminala. Una volta fatto selezioni "Nuova opzione di avvio" e inserisci la versione @TommyWorld68


Niente, sempre la stessa schermata.... ho rifatto il procedimento che mi hai detto più volte, ma niente.
Ti ringrazio comunque per il tempo @Gabri19

Magari @maxetto può aiutarti @TommyWorld68
Sempre disponibile e al vostro servizio!
Se vi sono stato d'aiuto ricordatevi di lasciare un like 
 e un rep cliccando sul +1 a sinistra!
Telegram: @GabrieleMc
Discussioni simili
Risposta di LEGO2002
30/11/2018, 15:17
Risposta di HogBoy96
08/11/2018, 23:04
 
3 163
Risposta di Criccu
07/11/2018, 23:03
 
[Crash] minecraft 1.13
5 238
Risposta di pietro140502
05/11/2018, 19:07
Risposta di PixelFederico
03/11/2018, 21:18

Utente(i) che stanno guardando questa discussione: 1 Ospite(i)