[Problema] BukkitGames

  • Pagine ({1}):
  • 1
  • 2
  • »
Salve ragazzi è da un po che non mi facevo sentire e sono ritornato con un problema!

plugin: BukkitGames
versione minecraft server: 1.7.2

ho inserito kit cecchino e il suo prezzo, se entro nel server mi dice prize:5 (ovvero il mio costo)
pero quando lo clicco mi da un errore questo perchè non ho inserito il permesso a permissionex
appena aggiungo il permesso e riavvio il server quando facico /kit e vado a cliccare il kit cecchino me lo da senza pagare.

note aggiuntive:
database aggiunto e sembra funzionante
io non sono operatore e nel pemissionex c'e solo il gruppo default quindi sto nel gruppo default

mentre il server è aperto xamp e sempre runnato correttamente.

un po di configurazioni:

config.yml (di bukkitgames)

Codice:
TIME:
# Max game length in minutes
  MAX_GAME-MIN: 90
  
# Final battle takes place after ... minutes
  INCREASE_DIFFICULTY-MIN: 50
  
# Countdown to the start of the game
  COUNTDOWN-SEC: 300
  
# Duration of invincibility.
  FINAL_COUNTDOWN-SEC: 60
  
# Define the messages. (You can use color codes in the MOTD, like '&e')
MESSAGE:
  WORLD_BORDER: You have reached the WorldBorder!
  SERVER_FULL: The server is full.
  GAME_PROGRESS: Game is in progress.
  MOTD_PROGRESS: '&cGame is in progress.'
  MOTD_COUNTDOWN: '&eGame begins in <time>.'
  NO_KIT_PERMISSION: You are not allowed to use this kit.
  HELP_MESSAGE: For help, visit tinyurl.com/HGHelp
  SERVER_TITLE: BukkitGames HG Server
  KIT_BUY_WEBSITE: Ask operator.

# Toggle the advanced chat-system. (HUD chat-system)
ADVANCED_CHAT: true

# Show tips throughout the game?
SHOW_TIPS: true 
  
# Add a line for each tip you want to display.
TIPS:
  - 'Some kits have special abilities.'
  - 'This server runs the BukkitGames plugin.'
  - 'GameMakers are invisible!'
  - 'Get help by typing in /help.'
  - 'Get information about a kit with /kitinfo [KitName].'
  
# Advcanced Abilities (DisguiseCraft needed!)
ADVANCED_ABILITIES: false

# Should the kitname displayed as prefix in the chat?
KIT_PREFIX: false

# Spawn cornucopia on start (see cornucopia.yml)
CORNUCOPIA: true

# Spawn feast (see feast.yml)
FEAST: true

# Radius of the world...
WORLD_BORDER_RADIUS: 300

# Minimum of players to start with.
MINIMUM_PLAYERS_START: 2

# Users which did not choose a kit, get the default kit (can be configured in the kit.yml)
DEFAULT_KIT: true

# If the plugin should use the item menu or the normal chat menu to display available kits
ITEM_MENU: true

# Enable or disable compass feature.
COMPASS: true

# Auto Update Compass (If true, may causes lag on the server!) COMPASS has to be enabled for this to work.
AUTO_COMPASS: false

# Team Function! If enabled players can add other players to their team!
TEAM: true

# Death signs mark Player death places! (Lines can be configured in deathsign.yml).
DEATH_SIGNS: true

# Regenerate world? (true: every round there will be a new world/ false: see world.yml for configs).
REGEN_WORLD: true

# If false, all players start the game at the spawn.
# If true, each player starts at a random spot. (May causes lag on some servers!)
RANDOM_START: false

# Last Winner gets alle Kits in the next round only on local server! (no Mysql is needed!)
SIMPLE_REWARD: false

# Winner-Reward-System (Mysql Database needed!, Configuration in kit.yml)
REWARD: true

# How many Coins you get for one kill? (Only effects when REWARD is enabled!)
COINS_FOR_KILL: 1

# How many Coins you get when you win a game? (Only effects when REWARD is enabled!)
COINS_FOR_WIN: 5

# If enabled, players can join server during the game and act like spectators (permissions node "bg.spectator" required)
SPECTATOR_SYSTEM: false

# Weather to use a MySQL database for statistics. (leaderboard.yml will still be used!)
MYSQL: true

# Fill in the information for the database if you set "MYSQL" to true.
HOST: 'localhost'
PORT: '3306'
USERNAME: 'root'
PASSWORD: 'dbpasswordcensurata'
DATABASE: 'hg'

# We recommend you to leave this at it is, it makes updating the plugin a lot easier...
AUTO_UPDATE: true

# We also recommend you to leave this at it is, or you will have to check every day if there is an update for BukkitGames
UPDATE_CHECK: true

il database e "hg"


kit.yml(bukkitgames)

Codice:
# If default kit is enabled in the config you can configure the default kit here
default:
  ITEMS:
    - '297,3'
  ABILITY:
    - 0
  POTION:
    - 0

# Add a section for each kit. EXAMPLE:
# kitname: [THE NAME - SAME AS ABOVE - HAS TO BE IN SMALL LETTERS]
#  ITEMS:  

#    - 'ITEM_IDURABILITY,AMOUNT,ENCHANTMENT_ID,ENCHANTMENT_LEVEL'
#  ABILITY: 
#    - 0 [THE ID OF THE ABILITY - 0 IS NO ABILITY]
#  POTION: 
#    - POTION_ID,DURATION(IN SECONDS),AMPLIFIER [POTION_ID: 0 IS NO POTION, DURATION: 0 IS ENDLESS]
#  COINS: 0 [THE PRICE FOR THE KIT (if Reward is enabled in the config file), 0 this kit can not be bought]
# ITEMMENU: ITEM_ID [THE ID OF THE ITEM THAT WILL BE USED IN THE ITEMMENU FOR THAT KIT]

cecchino:
  ITEMS:
    - '261,1'
    - '262,64'
    - '298,1'
    - '300,1'
  ABILITY:
    - 0
  POTION:
    - 0
  COINS: 5
  ITEMMENU: 261

plugin:

-permissionex
-The Bukkit Games
-minecraftRKitPlugins

grazie in anticipo per tutte le risposte! (speriamo tante e di risolvere) o (poche e di risolvere) 
Ti sono stato di aiuto? Clicca sul tasto "+1" in basso a sinistra ! Smile
E' al 100% un errore con i permessi, non hai messo il file comunque. (Modificato 12/01/2014, 21:33 da filoghost.)
[Immagine: filoghost] filoghost
 
Sei fai il comando /coin funziona?
[Immagine: 2zxmhqr.gif]
1) Devi avere Reward Attivato dal config
2) devi fare /coin buy cecchino
Se sei admin su pex metti bg.kit.cecchino
si  se faccio /coin va, cmq pure non facendo /buy [kit] uno puo scegliere comunque il kit
Ti sono stato di aiuto? Clicca sul tasto "+1" in basso a sinistra ! Smile
Non puo, deve avere i diriti per prendere quelli a pagamento gratis...
tu nel permission ex setta:
Utente:
Diriti: 
bg.kit.nomedelkitgratis
ecc... 
Admin:
bg.kit.nomekitgratis
bg.kit.nomedelkitapagamento
(12/01/2014, 21:26)filoghost ha scritto: E' al 100% un errore con i permessi, non hai messo il file comunque.

(12/01/2014, 21:27)Giancky ha scritto: Sei fai il comando /coin funziona?

(12/01/2014, 22:01)LorenzoANDLORE ha scritto: 1) Devi avere Reward Attivato dal config
2) devi fare /coin buy cecchino
Se sei admin su pex metti bg.kit.cecchino
dopo aver impostato i coin al kit e riavvio server posso prendere comunque il kit gratis (powa)

(14/01/2014, 17:27)LorenzoANDLORE ha scritto: Non puo, deve avere i diriti per prendere quelli a pagamento gratis...
tu nel permission ex setta:
Utente:
Diriti: 
bg.kit.nomedelkitgratis
ecc... 
Admin:
bg.kit.nomekitgratis
bg.kit.nomedelkitapagamento

io ho configurato cosi i pex

user
    permissions:
    - bg.kit.powa
    - bg.kit.cecchino

kit powa a pagamento
kit cecchino gratis 
e gli utenti possono prendere tutto gratis (Modificato 15/01/2014, 16:46 da Legends.)
Ti sono stato di aiuto? Clicca sul tasto "+1" in basso a sinistra ! Smile
Nei permessi devi mettere solo quelli gratis, quelli a coin no, puoi prenderli solo se hai i coin. Invece se vuoi fare in modo che un admin prenda un kit a coin gratis gli metti il permesso bg.kit.nomedelkit
[Immagine: 2zxmhqr.gif]
(15/01/2014, 16:58)Giancky ha scritto: Nei permessi devi mettere solo quelli gratis, quelli a coin no, puoi prenderli solo se hai i coin. Invece se vuoi fare in modo che un admin prenda un kit a coin gratis gli metti il permesso bg.kit.nomedelkit

se non metto pex kit con coin non lo fa prendere
Ti sono stato di aiuto? Clicca sul tasto "+1" in basso a sinistra ! Smile
Ma per prendere un kit a coin dei fare /coin buy nomedelkit, fai così oppure ci clicchi come un kit gratis?
[Immagine: 2zxmhqr.gif]
  • Pagine ({1}):
  • 1
  • 2
  • »
Discussioni simili
 
[Domanda] BukkitGames
3 427
Risposta di Fiminecraft
12/08/2016, 22:14
Risposta di piersac
06/06/2016, 17:08
Risposta di Franck123321
05/06/2016, 13:42
 
[Domanda] Aiuto BukkitGames!
Risposta di Franck123321
30/05/2016, 08:18

Utente(i) che stanno guardando questa discussione: 1 Ospite(i)