[Problema] Essentials

Salve ragazzi, avrei una cosa da chiedervi
Ho un server craftbukkit 1.12.2 su cui ho installato vari plugins tra cui essentials, tuttavia un comando degli essentials non funziona e quando lo provo ad usare mi da errore.

Il comando è /lightining e questo è l'errore

[11:18:31 ERROR]: Command lightning failed:

java.lang.NoSuchMethodError: org.bukkit.entity.Player.getTargetBlock(Ljava/util/HashSet;I)Lorg/bukkit/block/Block;
at com.earth2me.essentials.commands.Commandlightning.run(Commandlightning.java:29) ~[EssentialsX-2.0.1.jar:?]
at com.earth2me.essentials.commands.EssentialsCommand.run(EssentialsCommand.java:162) ~[EssentialsX-2.0.1.jar:?]
at com.earth2me.essentials.commands.EssentialsCommand.run(EssentialsCommand.java:157) ~[EssentialsX-2.0.1.jar:?]
at com.earth2me.essentials.Essentials.onCommandEssentials(Essentials.java:514) [EssentialsX-2.0.1.jar:?]
at com.earth2me.essentials.Essentials.onCommand(Essentials.java:424) [EssentialsX-2.0.1.jar:?]
at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44) [craftbukkit-1.12.2.jar:git-Bukkit-57ab4cf]
at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:140) [craftbukkit-1.12.2.jar:git-Bukkit-57ab4cf]
at org.bukkit.craftbukkit.v1_12_R1.CraftServer.dispatchCommand(CraftServer.java:628) [craftbukkit-1.12.2.jar:git-Bukkit-57ab4cf]
at net.minecraft.server.v1_12_R1.PlayerConnection.handleCommand(PlayerConnection.java:1338) [craftbukkit-1.12.2.jar:git-Bukkit-57ab4cf]
at net.minecraft.server.v1_12_R1.PlayerConnection.a(PlayerConnection.java:1198) [craftbukkit-1.12.2.jar:git-Bukkit-57ab4cf]
at net.minecraft.server.v1_12_R1.PacketPlayInChat.a(SourceFile:37) [craftbukkit-1.12.2.jar:git-Bukkit-57ab4cf]
at net.minecraft.server.v1_12_R1.PacketPlayInChat.a(SourceFile:9) [craftbukkit-1.12.2.jar:git-Bukkit-57ab4cf]
at net.minecraft.server.v1_12_R1.PlayerConnectionUtils$1.run(SourceFile:13) [craftbukkit-1.12.2.jar:git-Bukkit-57ab4cf]
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_172]
at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_172]
at net.minecraft.server.v1_12_R1.SystemUtils.a(SourceFile:46) [craftbukkit-1.12.2.jar:git-Bukkit-57ab4cf]
at net.minecraft.server.v1_12_R1.MinecraftServer.D(MinecraftServer.java:696) [craftbukkit-1.12.2.jar:git-Bukkit-57ab4cf]
at net.minecraft.server.v1_12_R1.DedicatedServer.D(DedicatedServer.java:371) [craftbukkit-1.12.2.jar:git-Bukkit-57ab4cf]
at net.minecraft.server.v1_12_R1.MinecraftServer.C(MinecraftServer.java:651) [craftbukkit-1.12.2.jar:git-Bukkit-57ab4cf]
at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:555) [craftbukkit-1.12.2.jar:git-Bukkit-57ab4cf]
at java.lang.Thread.run(Thread.java:748) [?:1.8.0_172]


Sinceramente ho provato a leggere un po ma non ho capito molto nonostante non sia proprio incapace con programmi di questo genere. Se qualcuno sa come risolvere il problema sarebbe di grande aiuto. Grazie mille.
EssentialsX non è compatibile con CraftBukkit, usa Spigot.

E utilizza le versioni Dev di EssentialsX che sono sempre aggiornate per l'ultima versione di Minecraft: https://ci.ender.zone/job/EssentialsX/
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: dona-con-paypal.png]

Rip Maxcraft
Grazie per la risposta ma il mio essentials è compatibile con bukkit, non è quello ufficiale a quanto capito, ma apparte questo comando funziona perfettamente. Ecco il link:
https://dev.bukkit.org/projects/essentialsx

Comunque valuterò di usare spigot se gli altri plugins che uso saranno compatibili. Prima però vorrei sapere da cosa è causato quell'errore
13/07/2018, 15:30LordYozzi ha scritto: Grazie per la risposta ma il mio essentials è compatibile con bukkit, non è quello ufficiale a quanto capito, ma apparte questo comando funziona perfettamente. Ecco il link:
https://dev.bukkit.org/projects/essentialsx

Comunque valuterò di usare spigot se gli altri plugins che uso saranno compatibili. Prima però vorrei sapere da cosa è causato quell'errore

Nessuno usa più CraftBukkit dopo la 1.7 visto che il progetto Spigot è ormai maturo e molto meglio di CraftBukkit, pertanto ti invito a passare a Spigot.

Per quanto hai detto te, sì è compatibile con CraftBukkit visto che il plugin è stato scritto seguendo l'API di Bukkit e non di Spigot (che integra e migliora quella di Bukkit), tuttavia stai utilizzando la versione per 1.12 in un server 1.12.2.


Ribadisco quindi di utilizzare le Dev Builds che sono le più aggiornate e le più compatibili con le versioni recenti.
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: dona-con-paypal.png]

Rip Maxcraft
E Poi Spigot E stato Creato Principalmente da bukkit quindi alcuni plugin bukkit li puoi nettere su il server
Discussioni simili
 
4 111
Risposta di DonSnake
01/09/2018, 13:51
 
[Problema] Problema Essentials
2 111
Risposta di Wimowa
18/08/2018, 19:45
 
1 109
Risposta di Gabri19
05/08/2018, 18:22
Risposta di Gabri19
03/08/2018, 19:40
Risposta di Maxetto
26/06/2018, 23:45

Utente(i) che stanno guardando questa discussione: 1 Ospite(i)