[Problema] Ho un problema con un server minecraft su vps

Ciao a tutti, propio ieri un mio amico ha acquistato una vps su ovh abbiamo creato il server di minecraft ma ci da un piccolo problema appena il server è avviato entrando in minecraft e mettendo l'ip non va non logga non da la scritta loggin in.. vi chiedo un piccolo aiuto (: grazie in anticipo
ciao, serve qualche info in più, tipo:
hai accettato l'eula.txt?
hai fatto lo script di avviamento.sh?
esegui lo script tramite screen (per evitare di dover tenere aperto il collegamento ssh?)

guarda questo video, mi sembra che sia abbastanza corretto e ricontrolla tutto. p.s non è mio


[Immagine: 2cgbq6t.png]
Lo start.sh non è obbligatorio,infatti puoi fare partire spigot anche con java -jar spigot.jar (Modificato 24/04/2017, 13:29 da Francy2040.)
Francy2040 al vostro servizio
A caccia del Most Like'd (se ti sono stato di aiuto dammi 1 like)
Feed me likes , that's fine! Ahsese Asd
Mia vps 
 [Immagine: QRxhW05.png]
24/04/2017, 13:29Francy2040 ha scritto: Lo start.sh non è obbligatorio,infatti puoi fare partire spigot anche con java -jar spigot.jar

si ma è buona norma utilizzarlo, specialmente se non vuoi avere problemi con l'hosting, o tutelare le risorse utilizzate o ottimizzarle. mi vorrai dire che può essere anche fatto senza script.

ma comunque consiglio di specificare la ram minima e la ram massima in questo modo:

java -Xms2G -Xmx36G -jar spigot.jar

dove Xms sta per la ram minima (poi impostare un qualunque valore in base alle prestazioni necessarie)
e Xmx la ram massima (poi impostare un qualunque valore in base alle prestazioni necessarie)

anche il client avvia il gioco tramite una stringa che imposta la ram da utilizzare.

comunque in una gestione più avanzata lo script si può ampliare con auto restart, auto backup, ecc...
tutte informazioni presenti in rete
[Immagine: 2cgbq6t.png]
18/04/2017, 01:38MrTeraHD ha scritto: Ciao a tutti, propio ieri un mio amico ha acquistato una vps su ovh abbiamo creato il server di minecraft ma ci da un piccolo problema appena il server è avviato entrando in minecraft e mettendo l'ip non va non logga non da la scritta loggin in.. vi chiedo un piccolo aiuto (: grazie in anticipo

Il server si avvia correttamente?
La console non dà nessun tipo di errore?
Avete inserito l'IP del server nel file server.properties (server-ip=<ip server>)?
Avete controllato, sempre nel file server.properties, "server-port" sia 25565 (default)? Nel caso in qui ne usasse un altra dovete specificarla dopo l'ip del server (p. es. 0.0.0.0:25569, quindi nel file delle poprietà ci sarà server-port=25569).

Cosa vi dà come errore quando entrate nel server? "Unknow host"?

Spero di esserti stato utile.
In tal caso lascia un REP


Discussioni simili
 
5 72
Ultimo: Xray51YT
11 ore fa
 
[Problema] Chiudere le porte Vps
3 42
Ultimo: Checco_FT
11 ore fa
Ultimo: Maxetto
14/10/2017, 18:56
 
[Problema] OP su server.pro
Ultimo: Blue_Boy
08/10/2017, 11:26
07/10/2017, 14:00

Utente(i) che stanno guardando questa discussione: 1 Ospite(i)