[Problema] Hopper, items, commandblock, snapshot

Ciao a tutti, io nel mio mondo ho un randomizer di 9 outputs, fatto con 9 commandblock e alla fine di questa fila di commandblock c'è una torcia con vicino un hopper; sotto l'hopper c'è un dispenser/dropper che contiene 8 pezzi di lana (ognuno di un colore diverso) e dentro l'hopper c'è un pezzo di lana.
Il compito del commandblock è quello di "trovare" quel determinato items(ogni command block deve cercare il suo colore corrispondente es.:commandblock numero1 cerca la lana bianca, il 2 cerca la verde etc...). Il problema sta nel fatto che da quando ho introdotto lo snapshot 14w02a-b-c non funziona più.


Il comando è:testforblock COORDINATE hopper 8 {Items:[0:{Slot:0b,id:35s,Damage:IL_NUMERO_DEL_COLOREs,Count:1b}]}


SAPRESTE DARMI UN AIUTO?
Togli lo snapshot, è una versione incompleta.


Čïåõ ă țűťţī
My Config:
    MotherBoard: GigaByte 990 FX A-UD3 Ultra Durable
    CPU: AMD FX-8350 (8 core, 4.00GHz)
    Dissipatore: ThermalRight Macho HR-02 Rev.a
    RAM: Corsair Vengeance 8GB 4GBx2
    GPU: nVidia GTX 780 Asus OC
    PSU: Corsair CX 750M
    Case: Cooler Master 690 III Midi
    SSD 256GB
    HHD 1TB
    Masterizzatore
Invoco @mandelcube

inviato dal mio nexus 5 (Cataclysm) utilizzando Tapatalk
Ciao,
             SPAstef


penso non ce ne sia bisogno, non rompetegli i bal ogni due per tre!

inviato con TaTaPaTaLk (you don't say!)
"A profund text goes here"
 
                                       
Grazie=REP
Se volete il vostro banner qui, scrivetemi un pm!


Id Minecraft & skype: JohnnoNonno
--MESSAGGIO CANCELLATO--

Chiedo venia, avevo sbagliato di brutto ç_ç (Modificato 18/01/2014, 14:29 da MandelCube.)
Ok, ho controllato e per la parte verde hai ragione (ho imparato qualcosa di nuovo), ma sono quasi sicuro che il problema sia la parte rossa
Ho provato anchio (togliendo la parte rossa e facendo altre cose) ma senza risultato Sad
ALLELUIA !!!!!!! Ci ho messo un macello a capire ma alla fine e l'ho fatta :3

I problemi sono 2

- un hopper non può avere damage value uguale a 8, mettilo a 0 (puntato verso il basso);

- Dato che hanno messo gli ID nominali nelle NBT tag a quanto pare quelli numerici danno problemi, sostituisci id:35s con id:minecraft:wool nel tuo comando;

Purtroppo ho scoperto di essere un pò ignorante sul funzionamento di testforblock, quindi i miei precedenti commenti sulla parte rossa e su quella verde sono entrambi sbagliati (chiedo venia ç_ç).
@mandelcube se li cancelli si genera meno confusione.

inviato dal mio nexus 5 (Cataclysm) utilizzando Tapatalk
Ciao,
             SPAstef


Ho provato a fare come cosigliato da Mandelcube ma senza successoSad Se metto il damage value a 0 mi dice che non può, perchè l'hopper ha il damage value 8 pur essendo rivolto verso il basso. E poi dice comunque che non ha le NBT tag richieste(The block at 1594,55,-509 did not have the required NBT keys).
EDIT: HO SCOPERTO CHE FUNZIONA (prima ho fatto un macello). GRAZIE MILLESmile (Modificato 18/01/2014, 10:27 da fodre78.)
Discussioni simili
Risposta di alcatrak
15/07/2017, 16:22
Risposta di Sh4dowTV
29/06/2017, 23:59
 
[Risolto] Aiuto con l'hopper
Risposta di MRPuppetBN
16/04/2016, 15:04
 
[Domanda] commandblock
9 955
Risposta di OverDeath9
26/12/2015, 13:09
Risposta di BaccoShow
06/12/2015, 22:55

Utente(i) che stanno guardando questa discussione: 1 Ospite(i)