[Problema] Non mi va simpleprefix

  • Pagine ({1}):
  • 1
  • 2
  • »
ho scaricato simple prefix per i prefix ma quando li metto non vanno solo quelli dei gruppi ma i gruppi ogni persona oppata mette lo stesso prefix come faccio?
17/07/2018, 22:11TheLightCreeper ha scritto: ho scaricato simple prefix per i prefix ma quando li metto non vanno solo quelli dei gruppi ma i gruppi ogni persona oppata mette lo stesso prefix come faccio?

hai permisionex Se Si ci sono dei permessi da mettere e poi solo a gli oppati perchè hanno tutti i permessi loro a parte permissionex per questo invece se no che comando hai fatto per mettere i prefix

Permessi
Displays all colour codes
simpleprefix.command.colors

Add/remove prefix from specified group

simpleprefix.command.editGroups

Add/remove suffix from specified group
simpleprefix.command.editGroups

Add/remove prefix from a single player
simpleprefix.command.editIndividual

Add/remove suffix from a single player
simpleprefix.command.editIndividual

Add/remove prefix from yourself
simpleprefix.command.editOwn

Add/remove suffix from yourself
simpleprefix.command.editOw


Add/remove a world nickname
simpleprefix.command.editWorld

Reloads config from file
simpleprefix.command.reload

Permission for all commands
simpleprefix.command.*
17/07/2018, 22:11TheLightCreeper ha scritto: ho scaricato simple prefix per i prefix ma quando li metto non vanno solo quelli dei gruppi ma i gruppi ogni persona oppata mette lo stesso prefix come faccio?

Perdonami ma sinceramente non ho capito niente. Puoi provarlo a spiegare seguendo le regole grammaticali? Smile
SE TI SON STATO UTILE, UN  REP+ O UN LIKE MI FAREBBERO FELICE!
FAccio /spr prefix Founder, mi dice che lo ho messo, ma quando scrivo non c'è
18/07/2018, 15:21TheLightCreeper ha scritto: FAccio /spr prefix Founder, mi dice che lo ho messo, ma quando scrivo non c'è

Nel config hai impostato il prefix nel format della chat?
SE TI SON STATO UTILE, UN  REP+ O UN LIKE MI FAREBBERO FELICE!
Si l'ho fatto
18/07/2018, 17:32TheLightCreeper ha scritto: Si l'ho fatto

Non so se il comando /spr prefix <Prefix> è giusto perché sulla pagina Spigot c'è /spr p <Prefix>, prova ad usare quello.
Inoltre puoi inviare il contenuto del config?
Poi prova ad utilizzare /spr reload per aggiornare il prefix.
SE TI SON STATO UTILE, UN  REP+ O UN LIKE MI FAREBBERO FELICE!
Codice:
Auto-Update: true
Use-Vault: false
bungeecord: false
debug-mode: false
Template:
  format: '<[time] [world] [prefix][name][suffix]> '
  time: '[h:mm aa]'
  multiPrefix: false
  multiPrefixSeparator: '&r, '
  multiSuffix: false
  multiSuffixSeparator: '&r-'
Worlds:
  world:
    nickname: '&e[World]&f'
Group:
  example:
    prefix: '&4Staffer'
    suffix: ''
    tier: exampleTier
  default:
    prefix: member
User:
  069a79f4-44e9-4726-a5be-fca90e38aaf5:
    prefix: '&c[Notch]&f'
    suffix: ''
  'null':
    prefix: '&4Founder'
Version: 2.4.0
Ho provato /spr p Founder e comunque non va...
18/07/2018, 17:58TheLightCreeper ha scritto:
Codice:
Auto-Update: true
Use-Vault: false
bungeecord: false
debug-mode: false
Template:
  format: '<[time] [world] [prefix][name][suffix]> '
  time: '[h:mm aa]'
  multiPrefix: false
  multiPrefixSeparator: '&r, '
  multiSuffix: false
  multiSuffixSeparator: '&r-'
Worlds:
  world:
    nickname: '&e[World]&f'
Group:
  example:
    prefix: '&4Staffer'
    suffix: ''
    tier: exampleTier
  default:
    prefix: member
User:
  069a79f4-44e9-4726-a5be-fca90e38aaf5:
    prefix: '&c[Notch]&f'
    suffix: ''
  'null':
    prefix: '&4Founder'
Version: 2.4.0
Ho provato /spr p Founder e comunque non va...

Prova ad utilizzare Vault ed abilitarlo nel config.
SE TI SON STATO UTILE, UN  REP+ O UN LIKE MI FAREBBERO FELICE!
Ho fatto vault:true e mi mette member come tag perchè ho messo ai default il tag member su permissionex, ma su pex sono founder perchè mi mette comuque il prefix member?
18/07/2018, 20:20TheLightCreeper ha scritto: Ho fatto vault:true e mi mette member come tag perchè ho messo ai default il tag member su permissionex, ma su pex sono founder perchè mi mette comuque il prefix member?

Dalla pagina ufficiale del plugin: « Simple Prefix can be configured to get the prefixes and suffixes from Vault supported chat plugins instead (PermissionsEx, bPermissions, etc.) ».

Con SimplePrefix, se utilizzi quindi dei plugins che usufruiscono di Vault per gestire la chat, potrai unicamente gestire l'ordine della chat e non i prefixes/suffixes. Credo che se non vuoi utilizzare questa funzione dovrai rimuovere Vault e/o PermissionsEx.
SE TI SON STATO UTILE, UN  REP+ O UN LIKE MI FAREBBERO FELICE!
Altri plugin per mettere i prefix da consigliarmi?
18/07/2018, 21:44TheLightCreeper ha scritto: Altri plugin per mettere i prefix da consigliarmi?

Semplicemente PermissionsEx. Non va bene?

p.s. 900° messaggio. Smile (Modificato 18/07/2018, 21:56 da Maruzziello.)
SE TI SON STATO UTILE, UN  REP+ O UN LIKE MI FAREBBERO FELICE!
No ho scaricato anche chatex per farlo andare ma niente non compaiono in chat con pex...
18/07/2018, 22:03TheLightCreeper ha scritto: No ho scaricato anche chatex per farlo andare ma niente non compaiono in chat con pex...

Puoi utilizzare semplicemente PermissionsEx, senza altri plugins. Utilizza il comando /pex group <Group> prefix <Prefix> per il prefisso.
SE TI SON STATO UTILE, UN  REP+ O UN LIKE MI FAREBBERO FELICE!
  • Pagine ({1}):
  • 1
  • 2
  • »
Discussioni simili
Risposta di mat1310
25/09/2018, 15:34
Risposta di DylanNesta_
15/08/2018, 11:17
 
2 113
Risposta di Maxetto
23/07/2018, 19:24
Risposta di herobrine99dan
22/07/2018, 17:30
Risposta di zanna1b2
22/07/2018, 12:05

Utente(i) che stanno guardando questa discussione: 1 Ospite(i)