PermissionEX

vipdiamond:
   permissions:
    - plotme.limit.5
    - essentials.sethome.multiple.vip
    - essentials.sethome.multiple
    - essentials.delhome
    - essentials.enderchest
    - essentials.signs.use.disposal
    - essentials.signs.use.warp
    - essentials.signs.use.buy
    - essentials.signs.use.sell
    - essentials.workbench
    - essentials.nick.format
    - essentials.nick.magic
    - essentials.signs.use.repair
    - essentials.fly
    - essential.fly
    - essentials.chat.color
    - essentials.nick
    - essentials.warps.*
    - essentials.warp.list
    - essentials.warp
    - essentials.tpahere
    - essentials.tpaccept
    - essentials.tpa
    - essentials.sethome.bed
    - essentials.sethome
    - essentials.spawn
    - essentials.msg
    - essentials.mail.send
    - essentials.mail
    - essentials.helpop
    - essentials.pay
    - essentials.balance
    - creativegates.use
    - lwc.protect
    - automessage.receive.default
    - modifyworld.*
    options:
      prefix: '&0&l[&4&lVipBerserk&0&l]&f' 
 
  worlds:
     world:
       permissions:
       - essentials.kit.vipdiamond




Dopo aver messo questo il plugin permission ex non worka piu.... sapete cosa ho sbagliato ?
Da un errore? Se si mandacelo. Poi che versione hai di permissionex? Se usi la 1.7.9 hai sbagliato a inserire worlds perchè va in cima e non in fondo
(Modificato 03/07/2015, 21:21 da DavideBlade.)
Se ti sono stato utile clicca sul pulsantino REP sotto il mio avatar!
03/07/2015, 21:19DavideBlade ha scritto: Da un errore? Se si mandacelo. Poi che versione hai di permissionex? Se usi la 1.7.9 hai sbagliato a inserire worlds perchè va in cima e non in fondo

Ottima intuizione, ma hai sbagliato a parsare (manca uno spazio, e uno spazio sbagliato in YAML manda tutto in errore). Altra informazione, il "world:" nella riga dopo "worlds:" deve essere sostituito con il nome del mondo dove si vuole rendere disponibile il kit. Inoltre, il permesso per i kit specifici è essentials.kits.<kit>.
(Era anche presente un permesso chiamato "essential.fly", oltre a quello giusto. Rimosso)

Corretto:
Codice:
vipdiamond:
   worlds:
     world:
       permissions:
       - essentials.kits.vipdiamond
   permissions:
    - plotme.limit.5
    - essentials.sethome.multiple.vip
    - essentials.sethome.multiple
    - essentials.delhome
    - essentials.enderchest
    - essentials.signs.use.disposal
    - essentials.signs.use.warp
    - essentials.signs.use.buy
    - essentials.signs.use.sell
    - essentials.workbench
    - essentials.nick.format
    - essentials.nick.magic
    - essentials.signs.use.repair
    - essentials.fly
    - essentials.chat.color
    - essentials.nick
    - essentials.warps.*
    - essentials.warp.list
    - essentials.warp
    - essentials.tpahere
    - essentials.tpaccept
    - essentials.tpa
    - essentials.sethome.bed
    - essentials.sethome
    - essentials.spawn
    - essentials.msg
    - essentials.mail.send
    - essentials.mail
    - essentials.helpop
    - essentials.pay
    - essentials.balance
    - creativegates.use
    - lwc.protect
    - automessage.receive.default
    - modifyworld.*
    options:
      prefix: '&0&l[&4&lVipBerserk&0&l]&f'
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: dona-con-paypal.png]

Rip Maxcraft
Maxetto, ho inserito il tuo codice ma non va. Sapete dirmi se per caso è possibile da console fare ciò ?

Nel senso, da console fai pex group create < nome>
etc.... 

è possibile quindi aggiungere un permesso limitatamente ad un mondo selezionato ?
08/07/2015, 21:37Hyoku ha scritto: Maxetto, ho inserito il tuo codice ma non va. Sapete dirmi se per caso è possibile da console fare ciò ?

Nel senso, da console fai pex group create < nome>
etc.... 

è possibile quindi aggiungere un permesso limitatamente ad un mondo selezionato ?

Per la documentazione dei comandi di PEX (che io personalmente non uso e sconsiglio), puoi guardare QUA.
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: dona-con-paypal.png]

Rip Maxcraft
@Hyoku dopo aver creato il gruppo puoi utilizzare il comando: /pex group <nome gruppo> add <permesso> <mondo> per settare un permesso solo nel mondo in cui hai specificato così da evitare di sbagliare a inserire gli spazzi direttamente nel .yml.
Se ti sono stato utile clicca sul pulsantino REP sotto il mio avatar!
Discussioni simili
Ultima risposta: frova
01/11/2017, 17:25
Ultima risposta: Dracke
30/10/2017, 08:23
Ultima risposta: Maxetto
16/10/2017, 17:39
 
[Problema] Problema PermissionEx
Ultima risposta: gamer891962
11/09/2017, 12:27

Utente(i) che stanno guardando questa discussione: 1 Ospite(i)