[Problema] Pex Default

Ciao a tutti. Nella discussione vecchia ho risolto e non ho risposto (scusate). Oggi ho un nuovo problema.
Quando entra un utente nuovo nel server non riceve i pex default e quindi non ha i permessi di fare home spawn ecc. e devo fare sempre /pex user tizio group set default.


Codice:
groups:
  Utente:
    default: true
    options:
      prefix: '&7&lUtente '
    permissions:
    - -bukkit.command.*
    - essentials.tpa
    - essentials.tpaccept
    - essentials.tpdeny
    - essentials.home
    - essentials.sethome
    - essentials.back
    - essentials.spawn
  helper:
    options:
      prefix: '&a&lHelper '
    permissions:
    - essentials.tpa
    - essentials.tpaccept
    - essentials.tpdeny
    - essentials.home
    - essentials.sethome
    - essentials.back
    - essentials.spawn
    - essentials.god
    - essentials.fly
    - essentials.nick
    - essentials.nickcolor
    - essentials.nick.color
    - essentials.vanish
    - essentials.v
    - essentials.tp
    - maxbans.tempban
    - maxbans.tempmute
    - maxbans.warn
    - maxbans.kick
  mod:
    options:
      prefix: '&9&lMod '
    permissions:
    - essentials.tpa
    - essentials.tpaccept
    - essentials.tpdeny
    - essentials.home
    - essentials.sethome
    - essentials.back
    - essentials.spawn
    - essentials.god
    - essentials.fly
    - essentials.nick
    - essentials.nickcolor
    - essentials.nick.color
    - essentials.vanish
    - essentials.v
    - essentials.tp
    - maxbans.tempban
    - maxbans.tempmute
    - maxbans.warn
    - maxbans.kick
    - maxbans.ban
    - maxbans.banip
    - maxbans.mute
  vip:
    options:
      prefix: '&a&lVip '
    permissions:
    - essentials.tpa
    - essentials.tpaccept
    - essentials.tpdeny
    - essentials.home
    - essentials.sethome
    - essentials.back
    - essentials.spawn
    - essentials.god
    - essentials.fly
    - essentials.nick
    - essentials.nickcolor
    - essentials.nick.color
  admin:
    options:
      prefix: '&c&lAdmin '
    permissions:
    - '*'
  developer:
    options:
      prefix: '&b&lDeveloper '
    permissions:
    - '*'
  builder:
    options:
      prefix: '&6&lBuilder '
    permissions:
    - '*'
schema-version: 1

Ho l'ultima versione di permissions ex e il server è solo 1.8 (Modificato 29/07/2015, 12:16 da Giark_RP.)
29/07/2015, 10:54Giamny98 ha scritto: Ciao a tutti. Nella discussione vecchia ho risolto e non ho risposto (scusate). Oggi ho un nuovo problema.
Quando entra un utente nuovo nel server non riceve i pex default e quindi non ha i permessi di fare home spawn ecc. e devo fare sempre /pex user tizio group set default.


Codice:
groups:
 Utente:
   default: true
   options:
     prefix: '&7&lUtente '
   permissions:
   - -bukkit.command.*
   - essentials.tpa
   - essentials.tpaccept
   - essentials.tpdeny
   - essentials.home
   - essentials.sethome
   - essentials.back
   - essentials.spawn
 helper:
   options:
     prefix: '&a&lHelper '
   permissions:
   - essentials.tpa
   - essentials.tpaccept
   - essentials.tpdeny
   - essentials.home
   - essentials.sethome
   - essentials.back
   - essentials.spawn
   - essentials.god
   - essentials.fly
   - essentials.nick
   - essentials.nickcolor
   - essentials.nick.color
   - essentials.vanish
   - essentials.v
   - essentials.tp
   - maxbans.tempban
   - maxbans.tempmute
   - maxbans.warn
   - maxbans.kick
 mod:
   options:
     prefix: '&9&lMod '
   permissions:
   - essentials.tpa
   - essentials.tpaccept
   - essentials.tpdeny
   - essentials.home
   - essentials.sethome
   - essentials.back
   - essentials.spawn
   - essentials.god
   - essentials.fly
   - essentials.nick
   - essentials.nickcolor
   - essentials.nick.color
   - essentials.vanish
   - essentials.v
   - essentials.tp
   - maxbans.tempban
   - maxbans.tempmute
   - maxbans.warn
   - maxbans.kick
   - maxbans.ban
   - maxbans.banip
   - maxbans.mute
 vip:
   options:
     prefix: '&a&lVip '
   permissions:
   - essentials.tpa
   - essentials.tpaccept
   - essentials.tpdeny
   - essentials.home
   - essentials.sethome
   - essentials.back
   - essentials.spawn
   - essentials.god
   - essentials.fly
   - essentials.nick
   - essentials.nickcolor
   - essentials.nick.color
 admin:
   options:
     prefix: '&c&lAdmin '
   permissions:
   - '*'
 developer:
   options:
     prefix: '&b&lDeveloper '
   permissions:
   - '*'
 builder:
   options:
     prefix: '&6&lBuilder '
   permissions:
   - '*'
schema-version: 1

Ho l'ultima versione di permissions ex e il server è solo 1.8

Ecco qua (default va messo dentro options):
Codice:
groups:
 Utente:
   options:
     default: true
     prefix: '&7&lUtente '
   permissions:
   - -bukkit.command.*
   - essentials.tpa
   - essentials.tpaccept
   - essentials.tpdeny
   - essentials.home
   - essentials.sethome
   - essentials.back
   - essentials.spawn
 helper:
   options:
     prefix: '&a&lHelper '
   permissions:
   - essentials.tpa
   - essentials.tpaccept
   - essentials.tpdeny
   - essentials.home
   - essentials.sethome
   - essentials.back
   - essentials.spawn
   - essentials.god
   - essentials.fly
   - essentials.nick
   - essentials.nick.color
   - essentials.vanish
   - essentials.v
   - essentials.tp
   - maxbans.tempban
   - maxbans.tempmute
   - maxbans.warn
   - maxbans.kick
 mod:
   options:
     prefix: '&9&lMod '
   permissions:
   - essentials.tpa
   - essentials.tpaccept
   - essentials.tpdeny
   - essentials.home
   - essentials.sethome
   - essentials.back
   - essentials.spawn
   - essentials.god
   - essentials.fly
   - essentials.nick
   - essentials.nick.color
   - essentials.vanish
   - essentials.v
   - essentials.tp
   - maxbans.tempban
   - maxbans.tempmute
   - maxbans.warn
   - maxbans.kick
   - maxbans.ban
   - maxbans.banip
   - maxbans.mute
 vip:
   options:
     prefix: '&a&lVip '
   permissions:
   - essentials.tpa
   - essentials.tpaccept
   - essentials.tpdeny
   - essentials.home
   - essentials.sethome
   - essentials.back
   - essentials.spawn
   - essentials.god
   - essentials.fly
   - essentials.nick
   - essentials.nick.color
 admin:
   options:
     prefix: '&c&lAdmin '
   permissions:
   - '*'
 developer:
   options:
     prefix: '&b&lDeveloper '
   permissions:
   - '*'
 builder:
   options:
     prefix: '&6&lBuilder '
   permissions:
   - '*'
schema-version: 1

P.S. Ma mettere un po' di Inheritance invece di scrivere lo stesso permesso in tutti i gruppi? Tongue
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: dona-con-paypal.png]

Rip Maxcraft
29/07/2015, 13:43Maxetto ha scritto:
29/07/2015, 10:54Giamny98 ha scritto: Ciao a tutti. Nella discussione vecchia ho risolto e non ho risposto (scusate). Oggi ho un nuovo problema.
Quando entra un utente nuovo nel server non riceve i pex default e quindi non ha i permessi di fare home spawn ecc. e devo fare sempre /pex user tizio group set default.


Codice:
groups:
 Utente:
   default: true
   options:
     prefix: '&7&lUtente '
   permissions:
   - -bukkit.command.*
   - essentials.tpa
   - essentials.tpaccept
   - essentials.tpdeny
   - essentials.home
   - essentials.sethome
   - essentials.back
   - essentials.spawn
 helper:
   options:
     prefix: '&a&lHelper '
   permissions:
   - essentials.tpa
   - essentials.tpaccept
   - essentials.tpdeny
   - essentials.home
   - essentials.sethome
   - essentials.back
   - essentials.spawn
   - essentials.god
   - essentials.fly
   - essentials.nick
   - essentials.nickcolor
   - essentials.nick.color
   - essentials.vanish
   - essentials.v
   - essentials.tp
   - maxbans.tempban
   - maxbans.tempmute
   - maxbans.warn
   - maxbans.kick
 mod:
   options:
     prefix: '&9&lMod '
   permissions:
   - essentials.tpa
   - essentials.tpaccept
   - essentials.tpdeny
   - essentials.home
   - essentials.sethome
   - essentials.back
   - essentials.spawn
   - essentials.god
   - essentials.fly
   - essentials.nick
   - essentials.nickcolor
   - essentials.nick.color
   - essentials.vanish
   - essentials.v
   - essentials.tp
   - maxbans.tempban
   - maxbans.tempmute
   - maxbans.warn
   - maxbans.kick
   - maxbans.ban
   - maxbans.banip
   - maxbans.mute
 vip:
   options:
     prefix: '&a&lVip '
   permissions:
   - essentials.tpa
   - essentials.tpaccept
   - essentials.tpdeny
   - essentials.home
   - essentials.sethome
   - essentials.back
   - essentials.spawn
   - essentials.god
   - essentials.fly
   - essentials.nick
   - essentials.nickcolor
   - essentials.nick.color
 admin:
   options:
     prefix: '&c&lAdmin '
   permissions:
   - '*'
 developer:
   options:
     prefix: '&b&lDeveloper '
   permissions:
   - '*'
 builder:
   options:
     prefix: '&6&lBuilder '
   permissions:
   - '*'
schema-version: 1

Ho l'ultima versione di permissions ex e il server è solo 1.8

Ecco qua (default va messo dentro options):
Codice:
groups:
 Utente:
   options:
     default: true
     prefix: '&7&lUtente '
   permissions:
   - -bukkit.command.*
   - essentials.tpa
   - essentials.tpaccept
   - essentials.tpdeny
   - essentials.home
   - essentials.sethome
   - essentials.back
   - essentials.spawn
 helper:
   options:
     prefix: '&a&lHelper '
   permissions:
   - essentials.tpa
   - essentials.tpaccept
   - essentials.tpdeny
   - essentials.home
   - essentials.sethome
   - essentials.back
   - essentials.spawn
   - essentials.god
   - essentials.fly
   - essentials.nick
   - essentials.nick.color
   - essentials.vanish
   - essentials.v
   - essentials.tp
   - maxbans.tempban
   - maxbans.tempmute
   - maxbans.warn
   - maxbans.kick
 mod:
   options:
     prefix: '&9&lMod '
   permissions:
   - essentials.tpa
   - essentials.tpaccept
   - essentials.tpdeny
   - essentials.home
   - essentials.sethome
   - essentials.back
   - essentials.spawn
   - essentials.god
   - essentials.fly
   - essentials.nick
   - essentials.nick.color
   - essentials.vanish
   - essentials.v
   - essentials.tp
   - maxbans.tempban
   - maxbans.tempmute
   - maxbans.warn
   - maxbans.kick
   - maxbans.ban
   - maxbans.banip
   - maxbans.mute
 vip:
   options:
     prefix: '&a&lVip '
   permissions:
   - essentials.tpa
   - essentials.tpaccept
   - essentials.tpdeny
   - essentials.home
   - essentials.sethome
   - essentials.back
   - essentials.spawn
   - essentials.god
   - essentials.fly
   - essentials.nick
   - essentials.nick.color
 admin:
   options:
     prefix: '&c&lAdmin '
   permissions:
   - '*'
 developer:
   options:
     prefix: '&b&lDeveloper '
   permissions:
   - '*'
 builder:
   options:
     prefix: '&6&lBuilder '
   permissions:
   - '*'
schema-version: 1

P.S. Ma mettere un po' di Inheritance invece di scrivere lo stesso permesso in tutti i gruppi? Tongue

Non ho capito quello che hai detto, ma vabbè grazie dell'aiuto ho risolto. Potete chiudere
29/07/2015, 16:30Giamny98 ha scritto:
29/07/2015, 13:43Maxetto ha scritto:
29/07/2015, 10:54Giamny98 ha scritto: Ciao a tutti. Nella discussione vecchia ho risolto e non ho risposto (scusate). Oggi ho un nuovo problema.
Quando entra un utente nuovo nel server non riceve i pex default e quindi non ha i permessi di fare home spawn ecc. e devo fare sempre /pex user tizio group set default.


Codice:
groups:
 Utente:
   default: true
   options:
     prefix: '&7&lUtente '
   permissions:
   - -bukkit.command.*
   - essentials.tpa
   - essentials.tpaccept
   - essentials.tpdeny
   - essentials.home
   - essentials.sethome
   - essentials.back
   - essentials.spawn
 helper:
   options:
     prefix: '&a&lHelper '
   permissions:
   - essentials.tpa
   - essentials.tpaccept
   - essentials.tpdeny
   - essentials.home
   - essentials.sethome
   - essentials.back
   - essentials.spawn
   - essentials.god
   - essentials.fly
   - essentials.nick
   - essentials.nickcolor
   - essentials.nick.color
   - essentials.vanish
   - essentials.v
   - essentials.tp
   - maxbans.tempban
   - maxbans.tempmute
   - maxbans.warn
   - maxbans.kick
 mod:
   options:
     prefix: '&9&lMod '
   permissions:
   - essentials.tpa
   - essentials.tpaccept
   - essentials.tpdeny
   - essentials.home
   - essentials.sethome
   - essentials.back
   - essentials.spawn
   - essentials.god
   - essentials.fly
   - essentials.nick
   - essentials.nickcolor
   - essentials.nick.color
   - essentials.vanish
   - essentials.v
   - essentials.tp
   - maxbans.tempban
   - maxbans.tempmute
   - maxbans.warn
   - maxbans.kick
   - maxbans.ban
   - maxbans.banip
   - maxbans.mute
 vip:
   options:
     prefix: '&a&lVip '
   permissions:
   - essentials.tpa
   - essentials.tpaccept
   - essentials.tpdeny
   - essentials.home
   - essentials.sethome
   - essentials.back
   - essentials.spawn
   - essentials.god
   - essentials.fly
   - essentials.nick
   - essentials.nickcolor
   - essentials.nick.color
 admin:
   options:
     prefix: '&c&lAdmin '
   permissions:
   - '*'
 developer:
   options:
     prefix: '&b&lDeveloper '
   permissions:
   - '*'
 builder:
   options:
     prefix: '&6&lBuilder '
   permissions:
   - '*'
schema-version: 1

Ho l'ultima versione di permissions ex e il server è solo 1.8

Ecco qua (default va messo dentro options):
Codice:
groups:
 Utente:
   options:
     default: true
     prefix: '&7&lUtente '
   permissions:
   - -bukkit.command.*
   - essentials.tpa
   - essentials.tpaccept
   - essentials.tpdeny
   - essentials.home
   - essentials.sethome
   - essentials.back
   - essentials.spawn
 helper:
   options:
     prefix: '&a&lHelper '
   permissions:
   - essentials.tpa
   - essentials.tpaccept
   - essentials.tpdeny
   - essentials.home
   - essentials.sethome
   - essentials.back
   - essentials.spawn
   - essentials.god
   - essentials.fly
   - essentials.nick
   - essentials.nick.color
   - essentials.vanish
   - essentials.v
   - essentials.tp
   - maxbans.tempban
   - maxbans.tempmute
   - maxbans.warn
   - maxbans.kick
 mod:
   options:
     prefix: '&9&lMod '
   permissions:
   - essentials.tpa
   - essentials.tpaccept
   - essentials.tpdeny
   - essentials.home
   - essentials.sethome
   - essentials.back
   - essentials.spawn
   - essentials.god
   - essentials.fly
   - essentials.nick
   - essentials.nick.color
   - essentials.vanish
   - essentials.v
   - essentials.tp
   - maxbans.tempban
   - maxbans.tempmute
   - maxbans.warn
   - maxbans.kick
   - maxbans.ban
   - maxbans.banip
   - maxbans.mute
 vip:
   options:
     prefix: '&a&lVip '
   permissions:
   - essentials.tpa
   - essentials.tpaccept
   - essentials.tpdeny
   - essentials.home
   - essentials.sethome
   - essentials.back
   - essentials.spawn
   - essentials.god
   - essentials.fly
   - essentials.nick
   - essentials.nick.color
 admin:
   options:
     prefix: '&c&lAdmin '
   permissions:
   - '*'
 developer:
   options:
     prefix: '&b&lDeveloper '
   permissions:
   - '*'
 builder:
   options:
     prefix: '&6&lBuilder '
   permissions:
   - '*'
schema-version: 1

P.S. Ma mettere un po' di Inheritance invece di scrivere lo stesso permesso in tutti i gruppi? Tongue

Non ho capito quello che hai detto, ma vabbè grazie dell'aiuto ho risolto. Potete chiudere

Significa che "prefix: <prefisso>" va messo dentro la sezione "options:", come per i permessi che vanno messi sotto "permissions:". (Modificato 29/07/2015, 16:39 da Maxetto.)
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: dona-con-paypal.png]

Rip Maxcraft
Discussioni simili
Risposta di EdwardTheKnight
31/07/2018, 12:24
Risposta di Davidebic_
15/07/2018, 12:24
 
[Domanda] Due pex temporanee
2 150
Risposta di AnonymousStar02
12/07/2018, 00:17
Risposta di EnderMark303
30/04/2018, 10:47

Utente(i) che stanno guardando questa discussione: 1 Ospite(i)