[Problema] Pex suffix e prefix non funzionano con EssentialsChat

  • Pagine (2):
  • 1
  • 2
  • »
Ciao a tutti,

nel config di PEX i suffix e i prefix sono impostati correttamente, ma Essentials me li blocca(il prefix lo si vede, il suffix non me lo fa vedere).

In gioco:

http://imgur.com/a/45YNj

PEX Config

http://imgur.com/a/adtYm

Essentials Config

http://imgur.com/a/xzXSk

Come vedete nel config di PEX dopo Founder c'è &6, che in teoria dovrebbe cambiare il colore del nome.Perchè non me lo cambia?

Ho inserito il suffix giusto( il suffix dovrebbe essere il colore del messaggio da quanto ho capito)però rimane bianco. Perchè?

Grazie in Anticipo. (Modificato 27/09/2016, 21:48 da Glowstoneman.)
Il Suffix non è il colore del messaggio (all'inizio lo pensavo anche io), è solo un'altro Prefix che sta dopo il nome (appunto, Suffix, che viene dopo).

Per colorare i messaggi devi sfruttare la sezione "group-formats" nel config di Essentials (Paragrafo EssentialsChat).

Il formato è così:

gruppo: formato messaggio


Es.
Codice:
Founder: '<{DISPLAYNAME}&r> &4{MESSAGE}'
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: dona-con-paypal.png]

[Immagine: banner.png]
E il colore del nome perchè non cambia?
28/09/2016, 12:21Glowstoneman ha scritto: E il colore del nome perchè non cambia?

Perché il DisplayName è gestito da Essentials e come tale devi modificarlo con "/nick <nome, colori e formati>"
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: dona-con-paypal.png]

[Immagine: banner.png]
Ok e non c'è modo di disabilitare questa funzione di essentials?
28/09/2016, 13:48Glowstoneman ha scritto: Ok e non c'è modo di disabilitare questa funzione di essentials?

Prova a impostare "change-displayname: false" nel config di Essentials. (Modificato 28/09/2016, 14:00 da Maxetto.)
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: dona-con-paypal.png]

[Immagine: banner.png]
Ho già provato ma quando lo faccio non mi mostra neanche il mio prefix
28/09/2016, 14:13Glowstoneman ha scritto: Ho già provato ma quando lo faccio non mi mostra neanche il mio prefix

Controlla di avere anche "add-prefix-suffix: true" nel config di Essentials (Dovrebbe anche esserci un cancelletto prima della riga, se è così, rimuovilo). (Modificato 28/09/2016, 18:28 da Maxetto.)
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: dona-con-paypal.png]

[Immagine: banner.png]
Scusa per la risposta in ritardo, comunque non va lo stesso.

ESSENTIALS Config:

http://imgur.com/a/Xj0lF

In gioco:

http://imgur.com/a/og3Rp (Modificato 28/09/2016, 19:55 da Glowstoneman.)
28/09/2016, 19:54Glowstoneman ha scritto: Scusa per la risposta in ritardo, comunque non va lo stesso.

ESSENTIALS Config:

http://imgur.com/a/Xj0lF

In gioco:

http://imgur.com/a/og3Rp

Allora usa il comando /nick, che problema c'è?

Se non vuoi l'ondina prima del nome basta impostare " nickname-prefix: '' "

Ricordati di reimpostare "change-displayname: true"


EDIT: Prima magari prova così:
- Reimposta "change-displayname: true"
- Imposta " ops-name-color: 'none' "
- Imposta alla fine del Prefix un colore.

Se tutto dovrebbe andare come penso, il colore alla fine del Prefix viene passato al colore del nome. Probabilmente non te lo faceva a te poiché eri OP e il colore rosso veniva forzato da Essentials. (Modificato 28/09/2016, 20:16 da Maxetto.)
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: dona-con-paypal.png]

[Immagine: banner.png]
  • Pagine (2):
  • 1
  • 2
  • »
Discussioni simili

Utente(i) che stanno guardando questa discussione: 1 Ospite(i)