[Problema] Plugin already initialized!

Ciao a tutti ho creato diversi plugin e usandoli uno alla volta sul server funzionano ma quando provo a inserirli tutti insieme mi da' questo errore:

Codice:
[17:32:57 ERROR]: Could not load 'plugins/ban.jar' in folder 'plugins'
[size=x-small][font=Menlo]org.bukkit.plugin.InvalidPluginException: java.lang.IllegalArgumentException: Plugin already initialized![/font][/size]
[size=x-small][font=Menlo] at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:133) ~[craftbukkit.jar:git-Bukkit-efe04b8][/font][/size]
[size=x-small][font=Menlo] at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:328) ~[craftbukkit.jar:git-Bukkit-efe04b8][/font][/size]
[size=x-small][font=Menlo] at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [craftbukkit.jar:git-Bukkit-efe04b8][/font][/size]
[size=x-small][font=Menlo] at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:289) [craftbukkit.jar:git-Bukkit-efe04b8][/font][/size]
[size=x-small][font=Menlo] at org.bukkit.craftbukkit.v1_8_R3.CraftServer.reload(CraftServer.java:718) [craftbukkit.jar:git-Bukkit-efe04b8][/font][/size]
[size=x-small][font=Menlo] at org.bukkit.Bukkit.reload(Bukkit.java:544) [craftbukkit.jar:git-Bukkit-efe04b8][/font][/size]
[size=x-small][font=Menlo] at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:25) [craftbukkit.jar:git-Bukkit-efe04b8][/font][/size]
[size=x-small][font=Menlo] at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:140) [craftbukkit.jar:git-Bukkit-efe04b8][/font][/size]
[size=x-small][font=Menlo] at org.bukkit.craftbukkit.v1_8_R3.CraftServer.dispatchCommand(CraftServer.java:620) [craftbukkit.jar:git-Bukkit-efe04b8][/font][/size]
[size=x-small][font=Menlo] at org.bukkit.craftbukkit.v1_8_R3.CraftServer.dispatchServerCommand(CraftServer.java:606) [craftbukkit.jar:git-Bukkit-efe04b8][/font][/size]
[size=x-small][font=Menlo] at net.minecraft.server.v1_8_R3.DedicatedServer.aO(DedicatedServer.java:372) [craftbukkit.jar:git-Bukkit-efe04b8][/font][/size]
[size=x-small][font=Menlo] at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:336) [craftbukkit.jar:git-Bukkit-efe04b8][/font][/size]
[size=x-small][font=Menlo] at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:629) [craftbukkit.jar:git-Bukkit-efe04b8][/font][/size]
[size=x-small][font=Menlo] at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:537) [craftbukkit.jar:git-Bukkit-efe04b8][/font][/size]
[size=x-small][font=Menlo] at java.lang.Thread.run(Thread.java:745) [?:1.8.0_65][/font][/size]
[size=x-small][font=Menlo]Caused by: java.lang.IllegalArgumentException: Plugin already initialized![/font][/size]
[size=x-small][font=Menlo] at org.bukkit.plugin.java.PluginClassLoader.initialize(PluginClassLoader.java:98) ~[craftbukkit.jar:git-Bukkit-efe04b8][/font][/size]
[size=x-small][font=Menlo] at org.bukkit.plugin.java.JavaPlugin.<init>(JavaPlugin.java:66) ~[craftbukkit.jar:git-Bukkit-efe04b8][/font][/size]
[size=x-small][font=Menlo] at net.gamersportal.main.Main.<init>(Main.java:10) ~[?:?][/font][/size]
[size=x-small][font=Menlo] at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:1.8.0_65][/font][/size]
[size=x-small][font=Menlo] at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62) ~[?:1.8.0_65][/font][/size]
[size=x-small][font=Menlo] at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) ~[?:1.8.0_65][/font][/size]
[size=x-small][font=Menlo] at java.lang.reflect.Constructor.newInstance(Constructor.java:422) ~[?:1.8.0_65][/font][/size]
[size=x-small][font=Menlo] at java.lang.Class.newInstance(Class.java:442) ~[?:1.8.0_65][/font][/size]
[size=x-small][font=Menlo] at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:52) ~[craftbukkit.jar:git-Bukkit-efe04b8][/font][/size]
[size=x-small][font=Menlo] at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:129) ~[craftbukkit.jar:git-Bukkit-efe04b8][/font][/size]
... 14 more


e si attiva solo il primo in ordine alfabetico, ciò succede solo con i miei plugin con quelli scaricati no,

Ho provato anche a cambiare il nome del jar prima di importarlo ma niente

come posso fare ? grazie
Hai cambiato il nome del Plugin nel plugin.yml? Hai dato nomi diversi al Package?
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: dona-con-paypal.png]

Rip Maxcraft
@Maxetto

Nel plugin.yml il nome è diverso per ogni plugin.
Per i package utilizzo sempre net.ilmiosito.nomeplugin ed in questo aggiungo la classe main mentre per i comandi net.ilmiosito.commands e in questo ogni classe un comando.
Quindi dovrei dare un nome diverso al posto di commands o cambiare anche ilmiosito?
Grazie per l'aiuto Smile

Inviato dal mio SM-G920F utilizzando Tapatalk
15/09/2016, 19:52xX_charbania_Xx ha scritto: @Maxetto

Nel plugin.yml il nome è diverso per ogni plugin.
Per i package utilizzo sempre net.ilmiosito.nomeplugin ed in questo aggiungo la classe main mentre per i comandi net.ilmiosito.commands e in questo ogni classe un comando.
Quindi dovrei dare un nome diverso al posto di commands o cambiare anche ilmiosito?
Grazie per l'aiuto Smile

Inviato dal mio SM-G920F utilizzando Tapatalk

Probabilmente sbagli/ti sei dimenticato qualcosa, perché dai log che hai mandato il plugin "ban" carica la classe: Main.java, contenuta nel Package "net.gamersportal.main".
Codice:
at net.gamersportal.main.Main.<init>(Main.java:10) ~[?:?]

Se era come dicevi te, nei log doveva venire fuori invece: "net.gamersportal.ban.Main"


I comandi dovrebbero stare sotto il package: "net.gamersportal.ban.Commands" (Modificato 15/09/2016, 20:10 da Maxetto.)
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: dona-con-paypal.png]

Rip Maxcraft
Questo problema può essere causato da:
- Più classi estendono JavaPlugin
- Hai creato un oggetto della tua classe main
- Più plugins nel server hanno lo stesso nome nel plugin.yml
- Più plugins nel server hanno lo stesso package
Discussioni simili
 
[Domanda] Plugin Help
Ultima risposta: zBoringDrop
10/12/2017, 23:58
Ultima risposta: xNightmaree
10/12/2017, 20:58
Ultima risposta: BEANNIEBOY
08/12/2017, 11:45
Ultima risposta: S4lvious
07/12/2017, 00:29
Ultima risposta: CubeMat007
04/12/2017, 08:56

Utente(i) che stanno guardando questa discussione: 1 Ospite(i)