[Problema] Problema con il Dominio

Ciao ragazzi ho tre problemi:Uno di poca importanza e due di molta importanza.
Ho il mio dominio.eu che ho collagato a Cloudflare per comodità.
Ho una VPS e ci ho installato il mio server di minecraft, ts3 e apache(Web server).
Ora ognuno di questi ha il proprio CNAME e SRV.
Il server minecraft ha il dominio mc.mioserver.eu e play.mioserver.eu
Il server TS3 ha il dominio ts.mioserver.eu
Mentre il sito ha http://www.mioserver.eu, forum.mioserver.eu e store.mioserver.eu
Il problema però è il seguente:
Se io vado su chrome e digito l'indirizzo mc.mioserver.eu, mi porta alla paggina del sito.
Se vado su minecraft, e digito invece, l'indirizzo forum.mioserver.eu, mi fa connettere al server.
La stessa cosa succede con il TS3.Funziona anche se mi connetto con forum.mioserver.eu.
Io su cloudflare, ho creato 2 record per ogni server:
Un record CNAME: mc.mioserver.eu
Un Record SRV: che punta alla porta 25565 per il dominio mc.mioserver.eu. Naturalmente la porta cambia al variare del server, per il forum ho messo la porta 80.
Come posso risolvere?Sarà una piccolezza però voglio che se un utente digita su un browser, mc.mioserver.eu, esce come messaggio un errore o che la paggina non è disponibile, oppure, come creo un redirect, che quando digito mc.mioserver.eu oppure ts.mioserver.eu, mi manda alla paggina http://www.mioserver.eu?
Il secondo problema, invece riguarda il forum.
Ora usando XenForo come gestione del forum, questo problema è stato risolto.Io mi posso collegare tranquillamente a forum.mioserver.eu
Prima però usavamo MyBB, che però mi dava problemi.
Io mio collegavo a forum.mioserver.eu e andava tutto bene.Poi andavo a fare il login e noto che nella barra degli indirizzi, spunta il mio IP(L'ip pubblico del server) e non forum.mioserver.eu/login.
Come mai succede?Come potrei risolvere?(So che ora usando XenForo, questo problema non lo ho più però mi potrebbe servire per risolvere problemi legati a questo in futuro Smile )
Il terzo problema è invece, legato a CloudFlare.
CloudFlare, permette di nascondere il mio Ip pubblico, infatti quando attivo questa funzione e faccio ping http://www.mioserver.eu,
mi mostra l'ip pubblico di CloudFlare.
Il problema è che quando attivo questa funzione, i server non sono più raggiungibili.
Io volevo utilizzare CloudFlare, proprio perchè so che ha questa funzionalità, che per i server Minecraft è fantastica poichè i DDoS, non sono più un problema(Almeno spero).
Però avendo questo problema ho paura che "attaccano" i miei server.
Come risolvo?
Grazie per l'attenzione e scusate se avrò fatto qualche errore.
Ciaooo
Discussioni simili
Ultima risposta: N3rdSix123
03/12/2017, 16:25
Ultima risposta: Lafa_96
16/11/2017, 21:51
 
2 74
Ultima risposta: Nikox34
07/11/2017, 11:57
Ultima risposta: frova
01/11/2017, 17:23
Ultima risposta: Gam3king
22/10/2017, 18:46

Utente(i) che stanno guardando questa discussione: 1 Ospite(i)