[Problema] Problema plugin

Problema di versioni?
Mi servirebbero pochi plugin ma non va mai niente...MobcreeperMobcreeperMobcreeper
WorldEdit per costruire easy, permissionEx per gestire i permessi, essential così per comodità, qualcosa per claimare lo spawn la pvparena, la mobarena ecc... e basta!!!
AIUTATEMI PLEASEEE
Shini
Codice:
[08:23:41] [Server thread/INFO]: Starting minecraft server version 1.10.2

[08:23:41] [Server thread/INFO]: Loading properties

[08:23:41] [Server thread/INFO]: Default game type: SURVIVAL

[08:23:41] [Server thread/INFO]: Generating keypair

[08:23:41] [Server thread/INFO]: Starting Minecraft server on //////////////

[08:23:41] [Server thread/INFO]: Using epoll channel type

[08:23:42] [Server thread/INFO]: This server is running CraftBukkit version git-Bukkit-75a8885 (MC: 1.10.2) (Implementing API version 1.10.2-R0.1-SNAPSHOT)

[img=16x14]https://static.minecraft-hosting.pro/medias/severe.png[/img]
[08:23:42] [Server thread/ERROR]: Could not load 'plugins/Factions.jar' in folder 'plugins'

org.bukkit.plugin.UnknownDependencyException: MassiveCore

at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:219) [craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at org.bukkit.craftbukkit.v1_10_R1.CraftServer.loadPlugins(CraftServer.java:295) [craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at org.bukkit.craftbukkit.v1_10_R1.CraftServer.(CraftServer.java:257) [craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at net.minecraft.server.v1_10_R1.PlayerList.(PlayerList.java:70) [craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at net.minecraft.server.v1_10_R1.DedicatedPlayerList.(SourceFile:14) [craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at net.minecraft.server.v1_10_R1.DedicatedServer.init(DedicatedServer.java:184) [craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at net.minecraft.server.v1_10_R1.MinecraftServer.run(MinecraftServer.java:514) [craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at java.lang.Thread.run(Thread.java:745) [?:1.7.0_101]

[08:23:42] [Server thread/INFO]: [WorldEdit] Loading WorldEdit v6.1.3;7a097ca

[08:23:42] [Server thread/INFO]: [PermissionsEx] Loading PermissionsEx v1.23.4

[img=16x14]https://static.minecraft-hosting.pro/medias/warning.png[/img]
[08:23:42] [Server thread/WARN]: [PermissionsEx] This server is in offline mode. Unless this server is configured to integrate with a supported proxy (see http://dft.ba/-8ous), UUIDs *may not be stable*!

[08:23:42] [Server thread/INFO]: [Essentials] Loading Essentials vTeamCity

[08:23:42] [Server thread/INFO]: [EssentialsChat] Loading EssentialsChat vTeamCity

[08:23:42] [Server thread/INFO]: [EssentialsProtect] Loading EssentialsProtect vTeamCity

[08:23:42] [Server thread/INFO]: [EssentialsSpawn] Loading EssentialsSpawn vTeamCity

[08:23:42] [Server thread/INFO]: [EssentialsAntiBuild] Loading EssentialsAntiBuild vTeamCity

[08:23:42] [Server thread/INFO]: [EssentialsGeoIP] Loading EssentialsGeoIP vTeamCity

[img=16x14]https://static.minecraft-hosting.pro/medias/warning.png[/img]
[08:23:42] [Server thread/WARN]: **** SERVER IS RUNNING IN OFFLINE/INSECURE MODE!

[img=16x14]https://static.minecraft-hosting.pro/medias/warning.png[/img]
[08:23:42] [Server thread/WARN]: The server will make no attempt to authenticate usernames. Beware.

[img=16x14]https://static.minecraft-hosting.pro/medias/warning.png[/img]
[08:23:42] [Server thread/WARN]: While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.

[img=16x14]https://static.minecraft-hosting.pro/medias/warning.png[/img]
[08:23:42] [Server thread/WARN]: To change this, set "online-mode" to "true" in the server.properties file.

[08:23:42] [Server thread/INFO]: Preparing level "ciao"

[08:23:42] [Server thread/INFO]: Preparing start region for level 0 (Seed: 1426145478568640165)

[08:23:43] [Server thread/INFO]: Preparing spawn area: 36%

[08:23:44] [Server thread/INFO]: Preparing start region for level 1 (Seed: 1426145478568640165)

[08:23:45] [Server thread/INFO]: Preparing start region for level 2 (Seed: 1426145478568640165)

[08:23:45] [Server thread/INFO]: [WorldEdit] Enabling WorldEdit v6.1.3;7a097ca

[08:23:45] [Server thread/INFO]: WEPIF: Using the Bukkit Permissions API.

[08:23:45] [Server thread/INFO]: [WorldEdit] Using com.sk89q.worldedit.bukkit.adapter.impl.Spigot_v1_10_R1 as the Bukkit adapter

[img=16x14]https://static.minecraft-hosting.pro/medias/warning.png[/img]
[08:23:45] [Server thread/WARN]: [WorldEdit] WorldEdit has detected you are using Java 7 (based on detected version 1.7.0_101).

[img=16x14]https://static.minecraft-hosting.pro/medias/warning.png[/img]
[08:23:45] [Server thread/WARN]: [WorldEdit] WorldEdit will stop supporting Java less than version 8 in the future, due to Java 7 being EOL since April 2015. Please update your server to Java 8.

[08:23:45] [Server thread/INFO]: [PermissionsEx] Enabling PermissionsEx v1.23.4

[08:23:45] [Server thread/INFO]: [PermissionsEx] Initializing file backend

[img=16x14]https://static.minecraft-hosting.pro/medias/severe.png[/img]
[08:23:45] [Server thread/ERROR]: [PermissionsEx]

========== UNABLE TO LOAD PERMISSIONS BACKEND =========

Your configuration must be fixed before PEX will enable

Details: Error loading permissions file!

=======================================================

ru.tehkode.permissions.exceptions.PermissionBackendException: Error loading permissions file!

at ru.tehkode.permissions.backends.file.FileBackend.reload(FileBackend.java:321) ~[PermissionsEx-1.23.4.jar:?]

at ru.tehkode.permissions.backends.file.FileBackend.(FileBackend.java:120) ~[PermissionsEx-1.23.4.jar:?]

at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:1.7.0_101]

at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57) ~[?:1.7.0_101]

at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) ~[?:1.7.0_101]

at java.lang.reflect.Constructor.newInstance(Constructor.java:526) ~[?:1.7.0_101]

at ru.tehkode.permissions.backends.PermissionBackend.getBackend(PermissionBackend.java:392) ~[PermissionsEx-1.23.4.jar:?]

at ru.tehkode.permissions.backends.PermissionBackend.getBackend(PermissionBackend.java:367) ~[PermissionsEx-1.23.4.jar:?]

at ru.tehkode.permissions.PermissionManager.createBackend(PermissionManager.java:624) ~[PermissionsEx-1.23.4.jar:?]

at ru.tehkode.permissions.PermissionManager.setBackend(PermissionManager.java:606) ~[PermissionsEx-1.23.4.jar:?]

at ru.tehkode.permissions.PermissionManager.initBackend(PermissionManager.java:693) ~[PermissionsEx-1.23.4.jar:?]

at ru.tehkode.permissions.PermissionManager.(PermissionManager.java:67) ~[PermissionsEx-1.23.4.jar:?]

at ru.tehkode.permissions.bukkit.PermissionsEx.onEnable(PermissionsEx.java:175) [PermissionsEx-1.23.4.jar:?]

at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:292) [craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:329) [craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:404) [craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at org.bukkit.craftbukkit.v1_10_R1.CraftServer.enablePlugin(CraftServer.java:358) [craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at org.bukkit.craftbukkit.v1_10_R1.CraftServer.enablePlugins(CraftServer.java:320) [craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at net.minecraft.server.v1_10_R1.MinecraftServer.t(MinecraftServer.java:404) [craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at net.minecraft.server.v1_10_R1.MinecraftServer.l(MinecraftServer.java:369) [craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at net.minecraft.server.v1_10_R1.MinecraftServer.a(MinecraftServer.java:324) [craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at net.minecraft.server.v1_10_R1.DedicatedServer.init(DedicatedServer.java:243) [craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at net.minecraft.server.v1_10_R1.MinecraftServer.run(MinecraftServer.java:514) [craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at java.lang.Thread.run(Thread.java:745) [?:1.7.0_101]

Caused by: org.bukkit.configuration.InvalidConfigurationException: while parsing a block mapping

in 'string', line 2, column 3:

Utente:

^

expected , but found BlockMappingStart

in 'string', line 4, column 5:

options:

^

at org.bukkit.configuration.file.YamlConfiguration.loadFromString(YamlConfiguration.java:56) ~[craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at ru.tehkode.permissions.backends.file.FileConfig.loadFromString(FileConfig.java:68) ~[PermissionsEx-1.23.4.jar:?]

at org.bukkit.configuration.file.FileConfiguration.load(FileConfiguration.java:184) ~[craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at org.bukkit.configuration.file.FileConfiguration.load(FileConfiguration.java:130) ~[craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at ru.tehkode.permissions.backends.file.FileConfig.load(FileConfig.java:38) ~[PermissionsEx-1.23.4.jar:?]

at ru.tehkode.permissions.backends.file.FileBackend.reload(FileBackend.java:309) ~[PermissionsEx-1.23.4.jar:?]

... 23 more

Caused by: org.yaml.snakeyaml.parser.ParserException: while parsing a block mapping

in 'string', line 2, column 3:

Utente:

^

expected , but found BlockMappingStart

in 'string', line 4, column 5:

options:

^

at org.yaml.snakeyaml.parser.ParserImpl$ParseBlockMappingKey.produce(ParserImpl.java:570) ~[craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:158) ~[craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at org.yaml.snakeyaml.parser.ParserImpl.checkEvent(ParserImpl.java:143) ~[craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:224) ~[craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:155) ~[craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at org.yaml.snakeyaml.composer.Composer.composeMappingNode(Composer.java:229) ~[craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at org.yaml.snakeyaml.composer.Composer.composeNode(Composer.java:155) ~[craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at org.yaml.snakeyaml.composer.Composer.composeDocument(Composer.java:122) ~[craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at org.yaml.snakeyaml.composer.Composer.getSingleNode(Composer.java:105) ~[craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at org.yaml.snakeyaml.constructor.BaseConstructor.getSingleData(BaseConstructor.java:120) ~[craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at org.yaml.snakeyaml.Yaml.loadFromReader(Yaml.java:450) ~[craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at org.yaml.snakeyaml.Yaml.load(Yaml.java:369) ~[craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at org.bukkit.configuration.file.YamlConfiguration.loadFromString(YamlConfiguration.java:54) ~[craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at ru.tehkode.permissions.backends.file.FileConfig.loadFromString(FileConfig.java:68) ~[PermissionsEx-1.23.4.jar:?]

at org.bukkit.configuration.file.FileConfiguration.load(FileConfiguration.java:184) ~[craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at org.bukkit.configuration.file.FileConfiguration.load(FileConfiguration.java:130) ~[craftbukkit-1.10.2-R0.1.jar:git-Bukkit-75a8885]

at ru.tehkode.permissions.backends.file.FileConfig.load(FileConfig.java:38) ~[PermissionsEx-1.23.4.jar:?]

at ru.tehkode.permissions.backends.file.FileBackend.reload(FileBackend.java:309) ~[PermissionsEx-1.23.4.jar:?]

... 23 more

[08:23:45] [Server thread/INFO]: [PermissionsEx] Disabling PermissionsEx v1.23.4

[08:23:45] [Server thread/INFO]: WEPIF: Using the Bukkit Permissions API.

[08:23:45] [Server thread/INFO]: WEPIF: Using the Bukkit Permissions API.

[08:23:45] [Server thread/INFO]: [Essentials] Enabling Essentials vTeamCity

[08:23:45] [Server thread/INFO]: Bukkit version format changed. Version not checked.

[08:23:45] [Server thread/INFO]: git-Bukkit-75a8885 (MC: 1.10.2)

[08:23:45] [Server thread/INFO]: 1.10.2-R0.1-SNAPSHOT

[08:23:45] [Server thread/INFO]: Using locale en_GB

[08:23:45] [Server thread/INFO]: Using locale en_GB

[08:23:45] [Server thread/INFO]: Essentials: Using config file enhanced permissions.

[08:23:45] [Server thread/INFO]: Permissions listed in as player-commands will be given to all users.

[08:23:45] [Server thread/INFO]: [EssentialsChat] Enabling EssentialsChat vTeamCity

[08:23:45] [Server thread/INFO]: [EssentialsProtect] Enabling EssentialsProtect vTeamCity

[08:23:45] [Server thread/INFO]: [EssentialsSpawn] Enabling EssentialsSpawn vTeamCity

[08:23:45] [Server thread/INFO]: [EssentialsAntiBuild] Enabling EssentialsAntiBuild vTeamCity

[08:23:46] [Server thread/INFO]: [EssentialsGeoIP] Enabling EssentialsGeoIP vTeamCity

[08:23:46] [Server thread/INFO]: [EssentialsGeoIP] This product includes GeoLite data created by MaxMind, available from http://www.maxmind.com/.

[08:23:46] [Server thread/INFO]: Server permissions file permissions.yml is empty, ignoring it

[08:23:46] [Server thread/INFO]: Done (3.651s)! For help, type "help" or "?"
Shini
Factions se non ho capito male necessita di MassiveCore. Il tuo server è in offline mode. Perciò non funziona Pex. Aggiorna la tua versione di Java a 1.8. Cancella la cartella di Pex per far ricreare il config.yml e metti Spigot al posto di CraftBukkit

Inviato dal mio Galaxy Nexus utilizzando Tapatalk
[Immagine: 388553.png]
Allora, per quanto riguarda strettamente l'errore (user0001 ti ha dato anche consigli extra):
- Per Factions serve MassiveCore (Con lo stesso numero di versione del Factions).
- L'avviso di PEX si riferisce al fatto che in Offline Mode i permessi richiedono che l'utente sia Online e che gli UUID sono calcolati sul Nome in Case-Sensitive (Mario è diverso da mARIO), ma non devi preoccuparti di ciò.
- L'errore di PEX invece si riferisce al fatto che il tuo permissions.yml è formattato male (non hai messo alcuno spazio?), controlla la sua giustezza QUA (ti aiuterà anche a capire dove sono gli errori e risolverli).
- WorldEdit ti avvisa che presto smetterà di funzionare con Java 7 e ti consiglia di aggiornare a Java 8. Siccome sei in un Hosting e al momento non ti interessa, ignora pure questo avviso.

E basta. Tutto qua. (Modificato 17/09/2016, 14:16 da Maxetto.)
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: dona-con-paypal.png]

Rip Maxcraft
1 utente apprezza questo post
Grazie mille!
Shini
Discussioni simili
Ultimo: xLadyGen_
21/10/2017, 13:33
Ultimo: lox1934
18/10/2017, 18:45
Ultimo: Nicolas17
17/10/2017, 21:48
Ultimo: Maxetto
17/10/2017, 18:44
Ultimo: ViperKey_
16/10/2017, 21:37

Utente(i) che stanno guardando questa discussione: 1 Ospite(i)