[Release] Plugin HubThat

Premessa: Download finalmente Disponibile!


Salve a tutti, oggi vorrei presentarvi un Plugin che ho creato.
Con questo Plugin potrete impostare uno Spawn per ogni mondo, e settare una Hub per tutti i mondi.
Questo Plugin è compatibile con Essentials (non provoca bugs, disabilita il comando /spawn di Essentials rimpiazzandolo col suo) e con Multiverse-Core (per impostare lo spawn di Multiverse basta scriverere /mv setspawn).
Per tutte le informazioni, e il download, vi lascio la pagina di Spigot.
Comandi e Permessi:

Codice:
/hubthat - Permetti a un Giocatore di Usare il Comando Principale del Plugin - hubthat.help
/spawn - Permetti a un Giocatore di Andare allo Spawn - hubthat.spawn
/setspawn - Permetti a un Giocatore di Impostare lo Spawn - hubthat.setspawn
/bed - Permetti a un Giocatore di Andare al proprio Letto - hubthat.bed
/sethub - Permetti a un Giocatore di Impostare la Hub - hubthat.sethub
/hub - Permetti a un Giocatore di Andare alla Hub - hubthat.hub


So che non è un Plugin dei più utili e migliori, ma l'ho fatto in un'oretta soltanto e quindi non mi sono impegnato molto.
Molto presto rilascerò una versione in italiano, se avete consigli su cosa aggiungere/modificare o trovate bug non esitate a scrivermi Big Grin
Se avete consigli per altri Plugins, scrivetemi qui sotto e io valuterò l'idea di farli Big Grin. (Modificato 19/09/2014, 20:44 da Qwertylol.)
[Immagine: giphy.gif]
mi dispiace ma credo che sia un plugin inutile Sad
Interessante, sarebbe bello aggiungere le varie traduzioni in varie lingua (se vuoi per questo ti posso aiutare; in varie lingue intendo minimo 48!). Non so esperto di plugins di Bukkit, ma mi pare fico per chi vuole la pappa pronta. Aggiusta anche la licenza, il pubblico dominio mi sembra come minimo da pazzi se ci tieni.
Il plugin è inutile, ed anche op, visto che faccendo /bed potrai scappare dal pvp immagino...
28/06/2014, 16:15LorenzoANDLORE ha scritto: Il plugin è inutile, ed anche op, visto che faccendo /bed potrai scappare dal pvp immagino...
E chi ha detto che è indirizzato per serve Factions PvP? E se fosse un survival PvE?
@LorenzoANDLORE Basta non dare il permesso di usare /bed in pvp.
@LelixSuper non dovrei pagare per avere una licenza? (Modificato 28/06/2014, 17:08 da Qwertylol.)
[Immagine: giphy.gif]
28/06/2014, 17:06Qwertylol ha scritto: @LorenzoANDLORE Basta non dare il permesso di usare /bed in pvp.
@LelixSuper non dovrei pagare per avere una licenza?
Io intendo le licenze software xD
Comunque no, non devono essere acquistate le licenze!
ah XD
la GNU (General Public License version 3) GPLv3 va bene?
[Immagine: giphy.gif]
28/06/2014, 17:30Qwertylol ha scritto: ah XD
la GNU (General Public License version 3) GPLv3 va bene?
Quella che vuoi. La GNU GPLv3 ha le sue caratteristiche, informati online e decidi poi.
lol, ma è compatibile anche con multiverse-core?
28/06/2014, 15:59gamerover98 ha scritto: mi dispiace ma credo che sia un plugin inutile Sad
So che è poco utile, infatti ci ho anche messo poco a farlo XD
Ho fatto plugins più utili ma li tengo per il mio server u.u (magari rilascerò delle versioni aperte al pubblico).
Ho pure detto che se avete consigli da darmi non esitate a farlo.

28/06/2014, 18:15LorenzoANDLORE ha scritto: lol, ma è compatibile anche con multiverse-core?
Si, funziona pure con quello, ora lo scrivo in alto. (Se vuoi modificare lo spawn di multiverse devi fare /mv setspawn) (Modificato 13/07/2014, 11:30 da Qwertylol.)
[Immagine: giphy.gif]
UP! Release 1.1 - aggiunta Hub!
Scusate se scrivo solo ora questo messaggio, quando ho postato la release mi sono dimenticato di farlo XD
[Immagine: giphy.gif]
Questo progetto è in attesa di approvazione.
Ciò significa che questo progetto non sia conforme alle norme di questo sito e potrà essere disponibile solo per un breve periodo di tempo.
Vi avverto prima di scaricare qualsiasi cosa da questo progetto.
Non si può scaricare
Si ma non ci Gasiamo fosse Utile...
13/07/2014, 13:05LorenzoANDLORE ha scritto: Questo progetto è in attesa di approvazione.
Ciò significa che questo progetto non sia conforme alle norme di questo sito e potrà essere disponibile solo per un breve periodo di tempo.
Vi avverto prima di scaricare qualsiasi cosa da questo progetto.
Non si può scaricare
Lorenzo, non capisco perché dici che non sia conforme.
Se non l'hanno ancora approvato non è colpa mia, lamentati con loro.
Perché dovrebbe essere disponibile solo per un breve periodo di tempo?

Se vuoi domani ti metto il codice sorgente su github. (Modificato 13/07/2014, 23:52 da Qwertylol.)
[Immagine: giphy.gif]
Discussioni simili
Risposta di Sk3py
03/12/2018, 23:39
Risposta di fabiomailtrash
03/12/2018, 07:26
Risposta di xTryer_
27/11/2018, 17:30
Risposta di IRROS
27/11/2018, 15:42
Risposta di gamer891962
15/11/2018, 07:39

Utente(i) che stanno guardando questa discussione: 1 Ospite(i)