[Richiesta] ERRORE POGRAMMAZIONE PLUGIN

Salve sto creando Un Plugin (Sono all'inizio) e Gia Sto avendo Problemi Infatti Nelle zone In rosso mi da errore:

package luxitalia;
 
import org.bukkit.command.Command;
import org.bukkit.command.CommandSender;
import org.bukkit.entity.Player;
import org.bukkit.plugin.java.JavaPlugin;
 
public final class luxitalia extends JavaPlugin {
public void onEnabled ()
{

}

public void onDisable ()
{

}

public boolean onCommand(CommandSender sender, Command cmd, String Commandlabel, String[] args )
{
Player player = (Player) sender;
if (CommandLabel.equalsIgnoreCase("luxitalia"))
{
player.sendmessage(Chatcolor.BLUE + "Versione 1.0 Del Plugin Privato Lux Italia")
}
return false;

}
 
}

Aiutatemi non so come risolvere!cry @filoghost
controlla bene le maiuscole e le minuscole, CommandLabel deve essere Commandlabel, Chatcolor deve essere ChatColor
Basta passare il mouse sopra e ti dice cosa non va Smile
[Immagine: filoghost] filoghost
 
Si Filo Ma Lo Stesso Non Partexk Mi da altri errori!
Si ma leggi cosa c'è scritto, o almeno scrivilo qui! Per fare plugin devi già sapere utilizzare java.
[Immagine: filoghost] filoghost
 
@headhunts Grazie Mille Sei Un Genio Wink +1 Big Grin
13/04/2014, 11:39PokerFaceOwna ha scritto: @headhunts Grazie Mille Sei Un Genio Wink +1 Big Grin

Prego.
@hunterheads @filoghost Non Mi Da Errori Ma QUando vado nel server e scrivo /luxitalia non va

package luxitalia;
 
import org.bukkit.ChatColor;
import org.bukkit.command.Command;
import org.bukkit.command.CommandSender;
import org.bukkit.entity.Player;
import org.bukkit.plugin.java.JavaPlugin;
 
public final class luxitalia extends JavaPlugin {

public static luxitalia plugin;

public void onEnabled ()
{

}

public void onDisable ()
{

}

public boolean onCommand(CommandSender sender, Command cmd, String Commandlabel, String[] args )
{
Player player = (Player) sender;
if (Commandlabel.equalsIgnoreCase("luxitalia"))
{
player.sendMessage(ChatColor.BLUE + "Versione 1.0 Del Plugin Privato Lux Italia");
}
return false;

}
 
}
Codice:
public void onEnabled ()
deve essere
Codice:
public void onEnable ()
Non rispondo a richieste di supporto in privato!

Moderatore&Neswer
Sviluppatore

@alberto01 Ma Cosi' è Scritto Forse devo levare le parentesi graffe?
Discussioni simili
 
[Risolto] Plugin skyblock
Ultima risposta: Tranelloso
ieri, 15:42
Ultima risposta: Ventuj
ieri, 15:11
 
3 54
Ultima risposta: zBoringDrop
ieri, 00:21
 
[Richiesta] Plugin per Anti - Tab
Ultima risposta: GabrielGhost
19/02/2018, 13:12

Utente(i) che stanno guardando questa discussione: 1 Ospite(i)