[Risolto] Come metto un command block che mette un'altro command block?

Salve ragazzi!
Sono qua per chiedervi qual'è il comando per posizionare un command block che ha un comando che posiziona un'altro commandblock il quale posizina un blocco di redstone.

io sono arrivato a questa conclusione:
/setblock 1084 57 -836 minecraft:chain_command_block 3 {conditionMet:1b,Command:"setblock 1093 57 -842 minecraft:command_block 5 {Command:"setblock 1084 59 -837 minecraft:redstone_block"}"}

ma a quanto pare è sbagliata ç_ç

Piccole considerazioni:
/setblock 1084 57 -836 minecraft:chain_command_block 3 (giusto per la direzione del nuovo command block)
{conditionMet:1b (mi serve che sia un commandblock a catena, Condizionale e Sempre Attivo)
,Command: (il comando di questo nuovo command block)
setblock 1093 57 -842 minecraft:command_block 5 (quest'ultimo command block mi serve che sia orientato "in 5" a Impulso, non condizionale e Serve Redstone)
{Command:"setblock 1084 59 -837 minecraft:redstone_block" (il comando dell'ultimo command block che deve posizionare un blocco di redstone)
"}"}

@_@ non trovo il problema, help me pls
#Commandblockception
@Lup8 in quale versione esegui il comando?
Che la forza sia con voi!
Se un utente ti aiuta, tu ringrazialo con un +1 o un mi piace (o con un grazie)!

Non offro assistenza privata! Se hai bisogno di aiuto, apri una discussione!

[Immagine: ZXD4rZ.png][Immagine: F1B0270035EC4CA1ACED.png]

[Immagine: 06a.gif]
Giusto! non l'ho specificato @_@
la versione è la 1.12.2

(Per il problma che avevo ho risolto usando il clone di un command block già posizionato, però vorrei comunque sapere come fare a posizionare un commandblock che posiziona un command block!) (Modificato 02/06/2018, 11:14 da Lup8.)
02/06/2018, 11:09Lup8 ha scritto: Giusto! non l'ho specificato @_@
la versione è la 1.12.2
@Lup8 allora non saprei, mi dispiace.
Ho chiesto la versione perchè pensavo che usavi uno snapshot della 1.13, in cui sono cambiati i comandi (ad esempio, il blocco comandi che guarda verso l’alto ora credo che sia command_block[rotation=up], ma non ne sono sicuro)
Comunque, ti taggo alcuni esperti di comandi che conosco, magari loro sanno aiutarti
@Maca @Edo022 @iHeroN @MandelCube (chi lo sa, magari tornaSasaAsdHail )
EDIT: ho appena letto la modifica al messaggio. Stessa cosa, purtroppo non ho le competenze per aiutarti. L’unica cosa che posso consigliarti di fare è attendere che almeno una delle persone da me taggate (MandelCube compreso) rispondano. (Modificato 02/06/2018, 11:33 da pietro140502.)
Che la forza sia con voi!
Se un utente ti aiuta, tu ringrazialo con un +1 o un mi piace (o con un grazie)!

Non offro assistenza privata! Se hai bisogno di aiuto, apri una discussione!

[Immagine: ZXD4rZ.png][Immagine: F1B0270035EC4CA1ACED.png]

[Immagine: 06a.gif]
1 utente apprezza questo post
02/06/2018, 11:19Anakin_Skywalker ha scritto:
02/06/2018, 11:09Lup8 ha scritto: Giusto! non l'ho specificato @_@
la versione è la 1.12.2
@Lup8 allora non saprei, mi dispiace.
Ho chiesto la versione perchè pensavo che usavi uno snapshot della 1.13, in cui sono cambiati i comandi (ad esempio, il blocco comandi che guarda verso l’alto ora credo che sia command_block[rotation=up], ma non ne sono sicuro)
Comunque, ti taggo alcuni esperti di comandi che conosco, magari loro sanno aiutarti
@Maca @Edo022 @iHeroN @MandelCube (chi lo sa, magari tornaSasaAsdHail )
EDIT: ho appena letto la modifica al messaggio. Stessa cosa, purtroppo non ho le competenze per aiutarti. L’unica cosa che posso consigliarti di fare è attendere che almeno una delle persone da me taggate (MandelCube compreso) rispondano.
Ehi, ci sono anche io!


In ogni caso @Lup8 ecco il comando corretto:
Codice:
/setblock 1084 57 -836 minecraft:chain_command_block 3 replace {auto:1b,conditionMet:1b,Command:"setblock 1093 57 -842 minecraft:command_block 5 replace {auto:1b,Command:\"setblock 1084 59 -837  minecraft:redstone_block\"}"}
Ti spiego gli errori che hai fatto:
  1. Non hai messo replace/destroy/keep dopo il metadata
  2. Quando metti un testo con le virgolette dentro un testo con le virgolette devi mettere \ prima di esse per far capire che non stai chiudendo il comando
  3. Non hai messo auto:1b ai command block, e quindi non si attivavano
Se ti sono stato utile 
clicca su +1

[Immagine: Fo29yyU.png][Immagine: Vsfkgsk.png]

[Immagine: bOeKnoS.png]
2 utenti apprezzano questo post
02/06/2018, 11:53CommandLeo ha scritto: Ehi, ci sono anche io!
Lol, perdonami, ho messo i primi che mi erano venuti in menteAsd
Che la forza sia con voi!
Se un utente ti aiuta, tu ringrazialo con un +1 o un mi piace (o con un grazie)!

Non offro assistenza privata! Se hai bisogno di aiuto, apri una discussione!

[Immagine: ZXD4rZ.png][Immagine: F1B0270035EC4CA1ACED.png]

[Immagine: 06a.gif]
Arrivo sempre troppo tardi :c
1 utente apprezza questo post
02/06/2018, 13:18Edo022 ha scritto: Arrivo sempre troppo tardi :c
@Edo022 se ti può consolare, sappi che nessuno di quelli che ho taggato ha ancora risposto, quindi non solo tu arrivi tardiWink
Che la forza sia con voi!
Se un utente ti aiuta, tu ringrazialo con un +1 o un mi piace (o con un grazie)!

Non offro assistenza privata! Se hai bisogno di aiuto, apri una discussione!

[Immagine: ZXD4rZ.png][Immagine: F1B0270035EC4CA1ACED.png]

[Immagine: 06a.gif]
Welp unlucky sto senza 3G

Ha già risposto il grande @CommandLeo tho Patpat
 ♫~ Se ti sono stato d'aiuto puoi ringraziarmi cliccando su +1 REP ~♪
CBUser e CBDev dalla 1.8, taggami se hai problemi coi Command Block

[Immagine: U85qfto.png]
Clicca il logo per vedere il mio album di disegni ( ˘˘  )
2 utenti apprezzano questo post
Discussioni simili
Risposta di Ghast_hunter
ieri, 20:16
Risposta di iHeroN
05/11/2018, 19:34
Risposta di Edo022
21/10/2018, 13:23
 
[Domanda] Command Block
Risposta di WhiteFox98
18/10/2018, 20:50
Risposta di redstone_haker
25/09/2018, 18:54

Utente(i) che stanno guardando questa discussione: 1 Ospite(i)