[Risolto] Non esegue un comando in un command block

1.13/1.13.1


Come da titolo, stò riscontrando un problema con alcuni comandi. In pratica quando eseguo il comando dalla chat, tutto apposto, funziona, quando invece provo ad eseguirlo da un command block non funziona. Intendo specificare che non ricevo alcun messaggio d'errore. Metto quà sotto il comando, ditemi se sono io a sbagliare o se è colpa di Minecraft:


/execute if entity @e[tag=glass,tag=!tpd] run tag @e[tag=glass,tag=!tpd] add tpd
23/08/2018, 22:14Manuel_Bulletti ha scritto: 1.13/1.13.1


Come da titolo, stò riscontrando un problema con alcuni comandi. In pratica quando eseguo il comando dalla chat, tutto apposto, funziona, quando invece provo ad eseguirlo da un command block non funziona. Intendo specificare che non ricevo alcun messaggio d'errore. Metto quà sotto il comando, ditemi se sono io a sbagliare o se è colpa di Minecraft:


/execute if entity @e[tag=glass,tag=!tpd] run tag @e[tag=glass,tag=!tpd] add tpd

Prova a cambiare il comando in: /execute as @e[tag=glass,tag=!tpd] run tag @s add tpd
 ♫~ Se ti sono stato d'aiuto puoi ringraziarmi cliccando su +1 REP ~♪
CBUser e CBDev dalla 1.8, taggami se hai problemi coi Command Block

[Immagine: U85qfto.png]
Clicca il logo per vedere il mio album di disegni ( ˘˘  )
1 utente apprezza questo post
24/08/2018, 02:04Maca ha scritto:
23/08/2018, 22:14Manuel_Bulletti ha scritto: 1.13/1.13.1


Come da titolo, stò riscontrando un problema con alcuni comandi. In pratica quando eseguo il comando dalla chat, tutto apposto, funziona, quando invece provo ad eseguirlo da un command block non funziona. Intendo specificare che non ricevo alcun messaggio d'errore. Metto quà sotto il comando, ditemi se sono io a sbagliare o se è colpa di Minecraft:


/execute if entity @e[tag=glass,tag=!tpd] run tag @e[tag=glass,tag=!tpd] add tpd

Prova a cambiare il comando in: /execute as @e[tag=glass,tag=!tpd] run tag @s add tpd

Funziona! Grazie veramente per il tuo prezioso aiuto. Non so se il like che ti ho messo conta come reputazione, al massimo, mandami un'altro messaggio per dirmi come fare; diamo a Cesare ciò che è di Cesare, no? (Modificato 24/08/2018, 13:59 da Manuel_Bulletti.)
Chiudo per problema risolto Smile
[Immagine: MizYQZc.png]
Discussioni simili
Risposta di Ghast_hunter
13/11/2018, 20:16
Risposta di DCLMTT2004
07/11/2018, 20:50
Risposta di iHeroN
05/11/2018, 19:34
Risposta di Edo022
21/10/2018, 13:23
 
[Domanda] Command Block
Risposta di WhiteFox98
18/10/2018, 20:50

Utente(i) che stanno guardando questa discussione: 1 Ospite(i)