Il forum è in modalità sola lettura dal 16 giugno 2019, ora siamo su Discord. Altre informazioni

[Risolto] Non mi funziona bene il summon nell'execute

  • Pagine ({1}):
  • 1
  • 2
  • »
Scusate, io volevo provare a creare un tavolino su Mc con i command block.
è la mia prima creazione e ho preso spunto da TheRedEngineer.
Perciò ho provato a usare un CB
repeat, unconditional, always active
con il comando
/execute @e[name=TAVOLO] ~ ~ ~ /summon armor_stand ~ ~ ~
per fare in modo che quando spawno un mob chiamato TAVOLO mi crei l'armor stand.
Quello che non capisco è perché mi dia
[18:12:27] Failed to execute '/summon armor_stand ~ ~ ~' as TAVOLO
come output del CB (e ovviamente non mi spawni il'armor stand), mentre se al posto di
/execute @e[name=TAVOLO] ~ ~ ~ /summon armor_stand ~ ~ ~
metto
/execute @e[name=TAVOLO] ~ ~ ~ /summon LightningBolt ~ ~ ~
funziona benissimo. Consigli???

Grazie in anticipo
Sposto.
Player Tecnico

Redstoner e Farmer

Taggatemi o potrei non vedere il messaggio.
Scusa, non sapevo bene in che sezione fare la domanda.
19/01/2017, 18:15XEpicFra ha scritto: (omissis) ...se al posto di
/execute @e[name=TAVOLO] ~ ~ ~ /summon armor_stand ~ ~ ~
metto
/execute @e[name=TAVOLO] ~ ~ ~ /summon LightningBolt ~ ~ ~
funziona benissimo. Consigli???

Grazie in anticipo

In che versione sei? 1.9?

Ricordati che da 1.9 a 1.11 i nomi delle entità sono cambiati.

Per 1.9 /1.10 usa ArmorStand

Per 1.11 usa armor_stand
Aaaaaah, grazie mille:ero in 1.10!

Proprio non spaevo di questa modifica!
19/01/2017, 18:47XEpicFra ha scritto: Aaaaaah, grazie mille:ero in 1.10!

Proprio non spaevo di questa modifica!

Di niente!
Ho provato sia con armor_stand che con armorstand, anche ad aggiungere davanti ad entrambi minecraft: , ma non funziona comunque.

PERCHE'??? :s

P.S.: se guardo l'id dell'armor stand (in 1.10) mi dice comunque minecraft:armor_stand e non minecraft:armorstand come dicevi tu Macapple
19/01/2017, 18:55XEpicFra ha scritto: Ho provato sia con armor_stand che con armorstand, anche ad aggiungere davanti ad entrambi minecraft: , ma non funziona comunque.

PERCHE'??? :s

P.S.: se guardo l'id dell'armor stand (in 1.10) mi dice comunque minecraft:armor_stand e non minecraft:armorstand come dicevi tu Macapple

Oh. Devo essermi confuso allora.

Non so, prova a usare le tag anziché il Name.

/summon armor_stand ~ ~1 ~ {Tags:["Tavolo"]}

e

/execute @e[tag=Tavolo] ~ ~ ~ comando

dovrebbe andare.
19/01/2017, 19:12Macapple96 ha scritto:
19/01/2017, 18:55XEpicFra ha scritto: Ho provato sia con armor_stand che con armorstand, anche ad aggiungere davanti ad entrambi minecraft: , ma non funziona comunque.

PERCHE'??? :s

P.S.: se guardo l'id dell'armor stand (in 1.10) mi dice comunque minecraft:armor_stand e non minecraft:armorstand come dicevi tu Macapple

Oh. Devo essermi confuso allora.

Non so, prova a usare le tag anziché il Name.

/summon armor_stand ~ ~1 ~ {Tags:["Tavolo"]}

e

/execute @e[tag=Tavolo] ~ ~ ~ comando

dovrebbe andare.

Non capisco quello che vuoi dire.
Io intendevo che quando spawno un mob (nel mio caso un orso) rinominato TAVOLO mi apparisse un armorstand. Non capisco come intendi con i tag. Forse dare il tag all'orso e usare il tag anziché il nom nell'execute? però quella parte dell'execute funziona, è la seconda (quella che spawna l'armor stand) che fa le bizze.
19/01/2017, 19:21XEpicFra ha scritto:
19/01/2017, 19:12Macapple96 ha scritto:
19/01/2017, 18:55XEpicFra ha scritto: Ho provato sia con armor_stand che con armorstand, anche ad aggiungere davanti ad entrambi minecraft: , ma non funziona comunque.

PERCHE'??? :s

P.S.: se guardo l'id dell'armor stand (in 1.10) mi dice comunque minecraft:armor_stand e non minecraft:armorstand come dicevi tu Macapple

Oh. Devo essermi confuso allora.

Non so, prova a usare le tag anziché il Name.

/summon armor_stand ~ ~1 ~ {Tags:["Tavolo"]}

e

/execute @e[tag=Tavolo] ~ ~ ~ comando

dovrebbe andare.

Non capisco quello che vuoi dire.
Io intendevo che quando spawno un mob (nel mio caso un orso) rinominato TAVOLO mi apparisse un armorstand. Non capisco come intendi con i tag. Forse dare il tag all'orso e usare il tag anziché il nom nell'execute? però quella parte dell'execute funziona, è la seconda (quella che spawna l'armor stand) che fa le bizze.

Appunto in questo modo ti riferisci a QUELL'ARMORSTAND perché ha il Tag Tavolo.

Non uso i Name perché ogni tanto fanno le bizze.
Ma in questo caso non è il nome a fare le bizze perché quando faccio il summon del fulmine se c'è l'orso TAVOLO funziona, il problema è che non mi summona l'armor stand, quindi non riesco nemmeno a mettergli il tag
19/01/2017, 18:55XEpicFra ha scritto: Ho provato sia con armor_stand che con armorstand, anche ad aggiungere davanti ad entrambi minecraft: , ma non funziona comunque.

PERCHE'??? :s

P.S.: se guardo l'id dell'armor stand (in 1.10) mi dice comunque minecraft:armor_stand e non minecraft:armorstand come dicevi tu Macapple

Ti dice minecraft:armor_stand perché quello è l'id dell'item "Armor Stand" (è come uno spawner egg). L'id dell'entità per la 1.10 è ArmorStand
Se ti sono stato d'aiuto clicca su +1!
NON rispondo a richieste di aiuto in privato, se vuoi farmi notare qualcosa taggami con @EndBug!

[Immagine: K7Rrvcq.jpg]
 
Ricorda inoltre le maiuscole.

Le entità pre 1.11 sono case sensitive.

execute @e[type=ArmorStand] ~ ~ ~ funziona

mentre

execute @e[type=armorstand] ~ ~ ~ non funziona
19/01/2017, 21:15Macapple96 ha scritto: Ricorda inoltre le maiuscole.

Le entità pre 1.11 sono case sensitive.

execute @e[type=ArmorStand] ~ ~ ~ funziona

mentre

execute @e[type=armorstand] ~ ~ ~ non funziona

Guarda che per la 1.11 l'id è armor_stand anche per l'entità...
Se ti sono stato d'aiuto clicca su +1!
NON rispondo a richieste di aiuto in privato, se vuoi farmi notare qualcosa taggami con @EndBug!

[Immagine: K7Rrvcq.jpg]
 
Ah, ok!

Grazie mille a tutti!
  • Pagine ({1}):
  • 1
  • 2
  • »
Discussioni simili
Risposta di pietro140502
06/05/2019, 06:30
 
[Problema] execute
4 241
Risposta di france324
04/05/2019, 18:39
Risposta di _XLoryKillerX_
04/05/2019, 14:16
Risposta di Eng100
03/05/2019, 09:25
Risposta di Lollo3000_PRO
09/04/2019, 12:57

Utente(i) che stanno guardando questa discussione: 1 Ospite(i)