Il forum è in modalità sola lettura dal 16 giugno 2019, ora siamo su Discord. Altre informazioni

[Risolto] paper mc 1.7

è 2 giorni che cerco paperspigot su google ma tutto quello che trovo è solo **** dove c'era il download di paperspigot ma quel sito è stato chiuso. ho cercato dappertutto ma non trovo il download. anche sul sito ufficiale papermc c'è solo da 1.8 a 1.13. non c'è qualcuno che mi sa dire dove trovarlo. (non scrivete cerca su google perchè non si possono passare i link)
Passare i JAR precompilati di Minecraft è contro il DMCA della Mojang poiché contiene violazioni del loro codice.
Per evitare ciò Spigot e Paper si sono inventati dei metodi alternativi (BuildTools) per fare in modo che solo l'utente finale possa maneggiare il codice proprietario della Mojang, applicando successivamente delle Patch che modificano il codice e facendoti uscire fuori il JAR che noi chiamiamo Spigot, Paper, ecc ecc.

Pertanto, l'unico modo per scaricare PaperSpigot 1.7.10 discutibile in questo Forum è quello specificato nella pagina del sorgente di PaperSpigot:
1. Scaricati Maven 3 e Git
Codice:
sudo apt-get install maven git

2. Esegui questi comandi per scaricare, patchare e buildare PaperSpigot 1.7.10
Codice:
git clone https://github.com/PaperMC/Paper-1.7.git
cd Paper-1.7
git submodule update --init
./applyPatches.sh
mvn clean install

3. Recuperati il Jar che trovi nella cartella "build" dentro la cartella Paper-1.7.


P.S. La versione 1.7.10 è incredibilmente buggata e soggetta a dozzine di Exploit pubblici in rete già da tempo. Come ti consiglia lo sviluppatore di PaperSpigot, è meglio passare a versioni più recenti.
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: MnksU9y.png]

Rip Maxcraft
1 utente apprezza questo post
Grazie. Lo so che è priena di problemi la 1.7 ma per un practice serve

Anche se io ho centOS non Ubunto ma credo siano uguali i comandi tranne il primo

con l'ultimo comando ho questo errore

[ERROR] Failed to execute goal on project minecraft-server: Could not resolve dependencies for project org.github.paperspigot:minecraft-server:jar:1.7.10-SNAPSHOT: Failed to collect dependencies for [org.bukkit:minecraft-server:jar:1.7.10 (compile)]: Failed to read artifact descriptor for org.bukkit:minecraft-server:jar:1.7.10: Could not transfer artifact org.bukkit:minecraft-server:pom:1.7.10 from/to repobo-snap (http://repo.bukkit.org/content/groups/public): repo.bukkit.org: Name or service not known: Unknown host repo.bukkit.org: Name or service not known -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/displ...nException
[ERROR]
[ERROR] After correcting the problems, you can resume the build with the command
[ERROR]   mvn <goals> -rf :minecraft-server (Modificato 15/01/2019, 15:54 da Minettyx.)
Ok, nella cartella di Paper-1.7, vai dentro la cartella "MinecraftServer" e modifica con l'editor che preferisci il "pom.xml".
Cambia quindi questa stringa:
Codice:
<url>http://repo.bukkit.org/content/groups/public</url>

in questa:
Codice:
<url>https://maven.sk89q.com/repo/</url>
Poiché la Repo di Bukkit è morta, incredibilmente c'è un mirror nel server dello sviluppatore di WorldEdit.
In questo modo dovrebbe compilarti.
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: MnksU9y.png]

Rip Maxcraft
1 utente apprezza questo post
Ora va ma alla fine da questo anche se ho sostituito quello che dicevi

Codice:
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO]
[INFO] PaperSpigot-Parent ................................ SUCCESS [0.476s]
[INFO] Minecraft Server .................................. SUCCESS [12.373s]
[INFO] Minecraft Server Relocation ....................... SUCCESS [4.573s]
[INFO] PaperSpigot-API ................................... SUCCESS [29.206s]
[INFO] PaperSpigot ....................................... FAILURE [0.923s]
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 47.731s
[INFO] Finished at: Tue Jan 15 17:11:42 GMT+01:00 2019
[INFO] Final Memory: 45M/754M
[INFO] ------------------------------------------------------------------------
[ERROR] Plugin com.wolvereness:overmapped:0.0.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for com.wolvereness:overmapped:jar:0.0.2: Could not transfer artifact com.wolvereness:overmapped:pom:0.0.2 from/to bukkit-plugins (http://repo.bukkit.org/content/groups/public): repo.bukkit.org: Unknown host repo.bukkit.org -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException
[root@autoapi Paper-1.7]#

Credo sia sempre lo stesso motivi perche http://repo.bukkit.org/content/groups/public non va più

Ps: se riesci a risolvere magari ti do un euro (Modificato 15/01/2019, 17:19 da Minettyx.)
Sempre nella cartella Paper-1.7, dovrebbe averti creato qualche pom.xml riguardante PaperSpigot (nelle varie cartelle). Cerca qualsiasi referenza sempre a:
Codice:
<url>http://repo.bukkit.org/content/groups/public</url>

e questa volta cambialo con:
Codice:
<url>https://papermc.io/repo/service/rest/repository/browse/maven-public/</url>




Se non dovessi trovarlo, cerca per "overmapped", fra i vari pom.xml
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: MnksU9y.png]

Rip Maxcraft
1 utente apprezza questo post
Sta volta questo errore... forse ho sostiuito qualcosa che non dovevo?

Codice:
[ERROR] Plugin com.wolvereness:overmapped:0.0.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for com.wolvereness:overmapped:jar:0.0.2: Failure to find com.wolvereness:overmapped:pom:0.0.2 in https://papermc.io/repo/service/rest/repository/browse/maven-public/ was cached in the local repository, resolution will not be reattempted until the update interval of bukkit-plugins has elapsed or updates are forced -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException
15/01/2019, 18:20Minettyx ha scritto: Sta volta questo errore... forse ho sostiuito qualcosa che non dovevo?

Codice:
[ERROR] Plugin com.wolvereness:overmapped:0.0.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for com.wolvereness:overmapped:jar:0.0.2: Failure to find com.wolvereness:overmapped:pom:0.0.2 in https://papermc.io/repo/service/rest/repository/browse/maven-public/ was cached in the local repository, resolution will not be reattempted until the update interval of bukkit-plugins has elapsed or updates are forced -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException

Non hai sostituito niente di sbagliato, prova a mandare questo comando:
Codice:
mvn -U clean install
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: MnksU9y.png]

Rip Maxcraft
1 utente apprezza questo post
stesso errore

Codice:
[ERROR] Plugin com.wolvereness:overmapped:0.0.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for com.wolvereness:overmapped:jar:0.0.2: Could not find artifact com.wolvereness:overmapped:pom:0.0.2 in bukkit-plugins (https://papermc.io/repo/service/rest/repository/browse/maven-public/) -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException
15/01/2019, 21:01Minettyx ha scritto: stesso errore

Codice:
[ERROR] Plugin com.wolvereness:overmapped:0.0.2 or one of its dependencies could not be resolved: Failed to read artifact descriptor for com.wolvereness:overmapped:jar:0.0.2: Could not find artifact com.wolvereness:overmapped:pom:0.0.2 in bukkit-plugins (https://papermc.io/repo/service/rest/repository/browse/maven-public/) -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException

Strano... è presente quel file...

Boh, prova con quest'altra Repo:
Codice:
<url>http://maven.elmakers.com/repository/</url>
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: MnksU9y.png]

Rip Maxcraft
1 utente apprezza questo post
Ha funzionato!!! finalmente. cmq ho questo warning... sai se è qualcosa? grazie di avermi aiutato ti dono 1 euro appena posso
Ma dove si trova il file? perchè la cartella build non c'è

Codice:
[WARNING] paperspigot-api-1.7.10-R0.1-SNAPSHOT.jar, minecraft-server-1.7.10-SNAPSHOT.jar define 34 overlappping classes:
[WARNING]   - javax.annotation.RegEx
[WARNING]   - javax.annotation.concurrent.Immutable
[WARNING]   - javax.annotation.meta.TypeQualifierDefault
[WARNING]   - javax.annotation.meta.TypeQualifier
[WARNING]   - javax.annotation.Syntax
[WARNING]   - javax.annotation.Nonnull
[WARNING]   - javax.annotation.CheckReturnValue
[WARNING]   - javax.annotation.CheckForNull
[WARNING]   - javax.annotation.meta.TypeQualifierNickname
[WARNING]   - javax.annotation.MatchesPattern
[WARNING]   - 24 more...
[WARNING] jansi-1.8.jar, jline-2.6.jar define 26 overlappping classes:
[WARNING]   - org.fusesource.hawtjni.runtime.Library
[WARNING]   - org.fusesource.jansi.AnsiConsole$1
[WARNING]   - org.fusesource.jansi.Ansi$1
[WARNING]   - org.fusesource.jansi.AnsiString
[WARNING]   - org.fusesource.jansi.internal.Kernel32$COORD
[WARNING]   - org.fusesource.jansi.internal.CLibrary
[WARNING]   - org.fusesource.jansi.internal.Kernel32$SMALL_RECT
[WARNING]   - org.fusesource.jansi.Ansi$Erase
[WARNING]   - org.fusesource.jansi.Ansi$Color
[WARNING]   - org.fusesource.jansi.internal.Kernel32$CONSOLE_SCREEN_BUFFER_INFO
[WARNING]   - 16 more...
[WARNING] minecraft-server-1.7.10-SNAPSHOT.jar, paperspigot-1.7.10-R0.1-SNAPSHOT.jar define 405 overlappping classes:
[WARNING]   - org.apache.logging.log4j.core.appender.ConsoleAppender$ConsoleManagerFactory
[WARNING]   - net.minecraft.server.DispenseBehaviorArmor
[WARNING]   - net.minecraft.server.PathfinderGoalHurtByTarget
[WARNING]   - net.minecraft.server.MobEffectAttackDamage
[WARNING]   - net.minecraft.server.BlockGrass
[WARNING]   - net.minecraft.server.RandomPositionGenerator
[WARNING]   - net.minecraft.server.PacketPlayOutEntityMetadata
[WARNING]   - net.minecraft.server.PacketPlayOutPlayerInfo
[WARNING]   - net.minecraft.server.PacketPlayOutEntityLook
[WARNING]   - net.minecraft.server.EntityHuman
[WARNING]   - 395 more...
[WARNING] paperspigot-1.7.10-R0.1-SNAPSHOT.jar, jline-2.6.jar define 2 overlappping classes:
[WARNING]   - jline.internal.TerminalLineSettings
[WARNING]   - jline.AnsiWindowsTerminal
[WARNING] maven-shade-plugin has detected that some .class files
[WARNING] are present in two or more JARs. When this happens, only
[WARNING] one single version of the class is copied in the uberjar.
[WARNING] Usually this is not harmful and you can skeep these
[WARNING] warnings, otherwise try to manually exclude artifacts
[WARNING] based on mvn dependency:tree -Ddetail=true and the above
[WARNING] output
[WARNING] See http://docs.codehaus.org/display/MAVENUSER/Shade+Plugin
(Modificato 16/01/2019, 16:07 da Minettyx.)
Non dovrebbe dare problemi quel warning.

Il .JAR sta nella cartella "target", dentro la cartella del progetto principale (PaperSpigot?). Dovrebbe pesare fra i 10 e i 20 MB.
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: MnksU9y.png]

Rip Maxcraft
1 utente apprezza questo post
Discussioni simili
Risposta di Gam3r16
31/05/2019, 19:30
 
[Problema] ping - 1.13 1.12.2
Risposta di _FabioTNT
06/05/2019, 22:30
Risposta di zPivan
01/05/2019, 18:03
Risposta di Sladerix
24/04/2019, 15:27

Utente(i) che stanno guardando questa discussione: 1 Ospite(i)