[Risolto] Problema AuthMe

  • Pagine (2):
  • 1
  • 2
  • »
Server : 1.8
Plugins al momento: Essentials,EssentialsSpawn,EssentialsChat,PermissionsEX,ProtocolLib,Vault,AuthMe
Problema: AuthMe Reloaded (Ultima versione 5.4)

- Il problema si verifica non appena si effettua una registrazione, al primo RELOAD il server crasha generando queste eccezioni

Logs:
Codice:
[15:50:54] [Craft Scheduler Thread - 8/WARN]: Exception in thread "Craft Scheduler Thread - 8"
[15:50:54] [Craft Scheduler Thread - 8/WARN]: org.apache.commons.lang.UnhandledException: Plugin AuthMe v5.4-SNAPSHOT-b1750 generated an exception while executing task 62
    at org.bukkit.craftbukkit.v1_8_R1.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:56)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
    at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.NullPointerException
    at org.sqlite.PrepStmt.<init>(PrepStmt.java:42)
    at org.sqlite.Conn.prepareStatement(Conn.java:404)
    at org.sqlite.Conn.prepareStatement(Conn.java:399)
    at org.sqlite.Conn.prepareStatement(Conn.java:383)
    at fr.xephi.authme.datasource.SQLite.getAccountsRegistered(SQLite.java:482)
    at fr.xephi.authme.datasource.CacheDataSource.getAccountsRegistered(CacheDataSource.java:219)
    at fr.xephi.authme.initialization.DataSourceProvider.lambda$checkDataSourceSize$0(DataSourceProvider.java:95)
    at org.bukkit.craftbukkit.v1_8_R1.scheduler.CraftTask.run(CraftTask.java:71)
    at org.bukkit.craftbukkit.v1_8_R1.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:53)
    ... 3 more

[15:50:54] [Craft Scheduler Thread - 16/INFO]: [Vault] Checking for Updates ...

Come posso risolvere?


Grazie in anticipo (Modificato 02/08/2017, 16:03 da Simo931.)
@Simo931
Scarica una versione precedente.
Clicca sul pulsante +1 a sinistra di questo post se ti sono appena stato utile!

[Immagine: banner.png]
02/08/2017, 16:04zBoringDrop ha scritto: @Simo931
Scarica una versione precedente.

Ho già provato con la 5.3.3 e la 5.3.2 Stesso problema
Anzi,
Con la 5.3.2 e .3 mi da errori diversi del tipo "[AuthMe] THE SERVER IS GOING TO SHUT DOWN AS DEFINED IN THE CONFIGURATION!"
Prova la 5.2
Clicca sul pulsante +1 a sinistra di questo post se ti sono appena stato utile!

[Immagine: banner.png]
02/08/2017, 16:08zBoringDrop ha scritto: Prova la 5.2

Fatto, con la 5.2 non si avvia neanche e da il solito errore
[AuthMe] THE SERVER IS GOING TO SHUT DOWN AS DEFINED IN THE CONFIGURATION!
Invia l'errore completo
Clicca sul pulsante +1 a sinistra di questo post se ti sono appena stato utile!

[Immagine: banner.png]
02/08/2017, 16:15zBoringDrop ha scritto: Invia l'errore completo

Questo con la 5.2 - 5.3.2 - 5.3.3
- Il server non si avvia

Codice:
[16:11:27] [Server thread/INFO]: [AuthMe] Enabling AuthMe v5.2-b1542
[16:11:27] [Server thread/INFO]: [AuthMe] SQLite driver loaded
[16:11:27] [Server thread/INFO]: [AuthMe] SQLite Setup finished
[16:11:27] [Server thread/INFO]: [AuthMe] Hooked into PermissionsEx!
[16:11:27] [Server thread/INFO]: [AuthMe] Hooked successfully into Essentials
[16:11:27] [Server thread/WARN]: [AuthMe] Aborting initialization of AuthMe: [InjectorReflectionException]: Could not invoke constructor of class 'class fr.xephi.authme.command.CommandHandler'
[16:11:27] [Server thread/WARN]: [AuthMe] THE SERVER IS GOING TO SHUT DOWN AS DEFINED IN THE CONFIGURATION!
[16:11:27] [Server thread/INFO]: [AuthMe] Waiting for 0 tasks to finish
[16:11:27] [Server thread/INFO]: [AuthMe] AuthMe 5.2-b1542 disabled!
[16:11:27] [Server thread/INFO]: Server permissions file permissions.yml is empty, ignoring it
[16:11:27] [Server thread/INFO]: Done (1,947s)! For help, type "help" or "?"
[16:11:27] [Server thread/INFO]: Stopping server
[16:11:27] [Server thread/INFO]: [ProtocolLib] Disabling ProtocolLib v4.3.0
Questo con la 5.4
- Fa avviare il server e tutto, funziona ma quando faccio reload Crasha.
Codice:
[15:50:54] [Craft Scheduler Thread - 8/WARN]: Exception in thread "Craft Scheduler Thread - 8"
[15:50:54] [Craft Scheduler Thread - 8/WARN]: org.apache.commons.lang.UnhandledException: Plugin AuthMe v5.4-SNAPSHOT-b1750 generated an exception while executing task 62
    at org.bukkit.craftbukkit.v1_8_R1.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:56)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
    at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.NullPointerException
    at org.sqlite.PrepStmt.<init>(PrepStmt.java:42)
    at org.sqlite.Conn.prepareStatement(Conn.java:404)
    at org.sqlite.Conn.prepareStatement(Conn.java:399)
    at org.sqlite.Conn.prepareStatement(Conn.java:383)
    at fr.xephi.authme.datasource.SQLite.getAccountsRegistered(SQLite.java:482)
    at fr.xephi.authme.datasource.CacheDataSource.getAccountsRegistered(CacheDataSource.java:219)
    at fr.xephi.authme.initialization.DataSourceProvider.lambda$checkDataSourceSize$0(DataSourceProvider.java:95)
    at org.bukkit.craftbukkit.v1_8_R1.scheduler.CraftTask.run(CraftTask.java:71)
    at org.bukkit.craftbukkit.v1_8_R1.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:53)
    ... 3 more

[15:50:54] [Craft Scheduler Thread - 16/INFO]: [Vault] Checking for Updates ...
(Modificato 02/08/2017, 16:19 da Simo931.)
Prova a disabilitare nella 5.2 il database sqlite
Clicca sul pulsante +1 a sinistra di questo post se ti sono appena stato utile!

[Immagine: banner.png]
02/08/2017, 16:19zBoringDrop ha scritto: Prova a disabilitare nella 5.2 il database sqlite

Fatto, il problema persiste, il server con 5.2 si spegne in automatico
Mi sa che il problema è questo:
Could not invoke constructor of class 'class fr.xephi.authme.command.CommandHandler'

Di errori ne capisco poco :\
Prova ad usare l'ultima relase: http://ci.xephi.fr/job/AuthMeReloaded/
Clicca sul pulsante +1 a sinistra di questo post se ti sono appena stato utile!

[Immagine: banner.png]
  • Pagine (2):
  • 1
  • 2
  • »
Discussioni simili
Ultima risposta: Cezar_
03/12/2017, 11:43
 
[Problema] FastLogin & Authme
4 66
Ultima risposta: zSk3py_
28/11/2017, 17:33
 
[Risolto] Authme e WordGuard
Ultima risposta: ANTYILPRO
17/11/2017, 00:12
 
[Problema] authme problema
Ultima risposta: Maxetto
16/11/2017, 11:05
 
[Risolto] Authme
Ultima risposta: ANTYILPRO
12/11/2017, 16:01

Utente(i) che stanno guardando questa discussione: 1 Ospite(i)