Il forum è in modalità sola lettura dal 16 giugno 2019, ora siamo su Discord. Altre informazioni

[Risolto] Sbagliando la password durante il login mi teletrasporta alla Lobby

Ho installato AuthMe sul server login e AuthMeBungee su bungeecord (precisamente waterfall).
Ho configurato AuthMe in modo che dopo il login o il register il player viene spostato alla Lobby, però c'è un problema, se scrivo /login <password a caso che non è quella registrata> (es. /login jdbgekdn) mi fa accedere e mi tippa alla Lobby ugualmente. Potreste spiegarmi cosa ho sbagliato? Grazie in anticipo.

AuthMe config.yml:

AuthMeBungee config.yml:

Grazie in anticipo! (Modificato 18/11/2018, 16:07 da Cubey.)
Se la memoria non mi inganna in "authServers" devi inserire i server in cui per entrare devi essere autenticato, cioè tutti i server che NON hanno AuthMeReloaded.

Oltre a questo, devi avere AuthMeReloaded versione 5.4.0 o superiore (usa sempre l'ultima, ti conviene) e devi attivare "bungeecord: true" sia nel config di AuthMeReloaded che in quello di Spigot.

P.S. Sposto in "Plugins".
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: MnksU9y.png]

Rip Maxcraft
1 utente apprezza questo post
Il problema persiste, è tutto settato correttamente ma quando metto una password a caso continua a teletrasportarmi alla Lobby.
spigot.yml> bungeecord: true
AuthMe> config.yml> bungeecord: true
AuthMeBungee> Ho cancellato la stringa ''AuthLobby'' ma si rigenera al riavvio abrogandola con ''Lobby''

Ho appena tolto dalla cartella dei plugins di Bungeecord AuthMeBungee, il problema c'è ancora, quindi è causato da AuthMe suppongo.

Questo è il config.yml completo di AuthMe, avevo sbagliato a copiarlo:
(Modificato 18/11/2018, 19:46 da Cubey.)
Versione di AuthMeReloaded?
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: MnksU9y.png]

Rip Maxcraft
Io utilizzo la versione 5.4.0, ma penso sia un problema dovuto a qualche errore di configurazione perchè il config.yml di default non mi dà problemi.

@Maxetto ho appena scoperto che NON è un errore di configurazione perchè ho appena eliminato la cartella di AuthMe e l'ho fatta rigenerare.

- Quando inserisco la password correttamente e il server Lobby NON è online mi fa semplicemente accedere al server AuthLobby.

- Se sbaglio la password quando il server Lobby NON mi dà questo errore: Could not connect to a default or fallback server, please try again later: io.netty.channel.AbstractChannel$AnnotatedConnectException (Il solito errore del server Lobby offline).

- Se sbaglio password quando il server Lobby E' online mi spedisce nel server Lobby. (Modificato 18/11/2018, 20:15 da Cubey.)
Non saprei, prova a segnalare il Bug agli sviluppatori di AuthMeBungee, potrebbe essere effettivamente un problema:
https://github.com/AuthMe/AuthMeBungee/issues
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: MnksU9y.png]

Rip Maxcraft
Da quel che ho letto il sedicesimo report riguarda proprio questo caso in particolare. Per chi avesse mio stesso problema consiglierei di scaricare le versioni precedenti di AuthMe finchè il problema persiste per poi aggiornarlo nuovamente quando tutti i bugs saranno stati fixati. (Modificato 18/11/2018, 22:43 da Cubey.)
Il sedicesimo report indica una funzionalità che vorrebbero fosse aggiunta riguardante il fatto che se hai già effettuato il login e rientri tramite sessione, dovrebbe spostarti automaticamente nell'ultimo server in cui eri connesso; cosa che attualmente non fa.
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: MnksU9y.png]

Rip Maxcraft
Sì, lo so, ho realizzato dopo di cosa parlasse. Non avevo letto con attenzione.

PS. Ho segnalato il problema.
Ho risolto, il problema era dovuto a qualche problema con bungeecord oppure con la configurazione del paperspigot. Inpratica ho ricreato da capo il server prestando attenzione alla configurazione, adesso non mi dà più questo problema, acneh se non capisco a cosa era dovuto. Grazie @Maxetto per avermi aiutato ugualmente. Potete chiudere.
Discussioni simili
Risposta di carlo4
27/04/2019, 14:07
Risposta di Delphy_Aura
25/04/2019, 11:29
Risposta di xXDark_SideXx
13/04/2019, 15:47

Utente(i) che stanno guardando questa discussione: 1 Ospite(i)