Il 16 giugno 2019, il forum e le risorse diventeranno in sola lettura. Clicca qui per maggiori informazioni

[Risolto] TimeZone corretta ma orario sballato su Spigot

Salve.

Ho il mio Network Minecraft hostato su una VPS di GameHosting e ho notato dei problemi con alcuni plugins e con la parte dell’ora di Spigot.

Vi spiego meglio.
Ho settato la timezone del sistema operativo, e quando utilizzo il comando “date” da linea di comando (shell) mi dice l’ora corretta (quella italiana).

Il problema che é sorto è stato all’interno dei server minecraft. Col plugin che utilizzo per la TAB List è possibile mostrare l’orario del server. Nel mio server locale (sul mio pc) la dice corretta, peró quella del server hostato sulla VPS è di due ore indietro.

Ho quindi provato (da client SSH) ad accedere ad uno sei server e guardare bene l’ora che diceva quando eseguivo un comando e compararla con l’ora italiana e mi sono accorto di questo:

[Immagine: KWJz2Zm.jpg]

Ho quindi provato a resettare la timezone ed impostarla nuovamente, e durante la configurazione, mi è uscito questo, che sostengo essere il problema:

[Immagine: Fn4bNh6.jpg]

Qualcuno che sappia come cambiare quell’Universal Time ed impostarlo con l’ora italiana, in modo che pure Spigot lo utilizzi come riferimento per l’orario dei server? Grazie!
VISITA IL MIO SERVER!
REAPERMC | NETWORK

FACTIONS - LOTTI - VANILLA - SKYBLOCK


mc.reapermc.it



Hai già riavviato Spigot e/o il server?

Alcuni plugin hanno la necessità di impostargli una TimeZone nella configurazione (Fra quelli che ricordo, HolographicDisplays).
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: MnksU9y.png]

Rip Maxcraft
27/04/2019, 12:56Maxetto ha scritto: Hai già riavviato Spigot e/o il server?

Alcuni plugin hanno la necessità di impostargli una TimeZone nella configurazione (Fra quelli che ricordo, HolographicDisplays).

Ovviamente sì @Maxetto

EDIT: Il plugin che utilizzo non necessita di configurazioni da config (dato che non si può configurare la parte dell’ora).

Inoltre il problema come vedi appare in tutto il server, anche nella console i log sono di 2 ore indietro (Modificato 27/04/2019, 13:05 da zPivan.)
VISITA IL MIO SERVER!
REAPERMC | NETWORK

FACTIONS - LOTTI - VANILLA - SKYBLOCK


mc.reapermc.it



Prova a modificare lo script di avvio dei server e aggiungi "-Duser.timezone=Europe/Rome" prima del -jar.
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: MnksU9y.png]

Rip Maxcraft
27/04/2019, 17:27Maxetto ha scritto: Prova a modificare lo script di avvio dei server e aggiungi "-Duser.timezone=Europe/Rome" prima del -jar.

Ha funzionato perfettamente!
Grazie mille, risolto Smile
VISITA IL MIO SERVER!
REAPERMC | NETWORK

FACTIONS - LOTTI - VANILLA - SKYBLOCK


mc.reapermc.it



Discussioni simili
Risposta di Maxetto
21/05/2019, 12:33
 
[Problema] Warnig su Console
10 335
Risposta di Peppe73
21/05/2019, 09:44
Risposta di zPivan
01/05/2019, 18:03
Risposta di Maxetto
18/04/2019, 20:50

Utente(i) che stanno guardando questa discussione: 1 Ospite(i)