[Risolto] World Edit

Buongiorno popolo di Minecraft
Come state? Spero bene

Sono qui per chiedervi aiuto su uno dei plugin piu' famosi al mondo, WorldEdit

Ho un server Craftbukkit 1.8.8, e desideravo installare la versione 7.0.0 di WorldEdit
Nonostante cio' il plugin si rifiuta di attivarsi .-.

Alla console mi appaiono i seguenti errori:


Codice:
[WARNING] [WorldEdit] Failed to load the built-in legacy id registry

java.lang.NoSuchMethodError: com/google/common/base/Preconditions.checkState(ZLjava/lang/String;Ljava/lang/Object;Ljava/lang/Object;)V (loaded from file:/pro/bin/mc/craftbukkit/1.8.8/craftbukkit-1.8.8.jar by sun.misc.Launcher$AppClassLoader@a2dbda9) called from class com.sk89q.worldedit.registry.Registry (loaded from file:/home/gs-40475/plugins/worldedit-bukkit-7.0.0-beta-05.jar by org.bukkit.plugin.java.PluginClassLoader@5912dcce).

at com.sk89q.worldedit.registry.Registry.register(Registry.java:51) ~[worldedit-bukkit-7.0.0-beta-05.jar:?]

at com.sk89q.worldedit.registry.NamespacedRegistry.register(NamespacedRegistry.java:47) ~[worldedit-bukkit-7.0.0-beta-05.jar:?]

at com.sk89q.worldedit.world.block.BlockTypes.register(BlockTypes.java:644) ~[worldedit-bukkit-7.0.0-beta-05.jar:?]

at com.sk89q.worldedit.world.block.BlockTypes.register(BlockTypes.java:640) ~[worldedit-bukkit-7.0.0-beta-05.jar:?]

at com.sk89q.worldedit.world.block.BlockTypes.<clinit>(BlockTypes.java:33) ~[worldedit-bukkit-7.0.0-beta-05.jar:?]

at com.sk89q.worldedit.extension.factory.parser.DefaultBlockParser.parseLogic(DefaultBlockParser.java:261) ~[worldedit-bukkit-7.0.0-beta-05.jar:?]

at com.sk89q.worldedit.extension.factory.parser.DefaultBlockParser.parseFromInput(DefaultBlockParser.java:82) ~[worldedit-bukkit-7.0.0-beta-05.jar:?]

at com.sk89q.worldedit.extension.factory.parser.DefaultBlockParser.parseFromInput(DefaultBlockParser.java:55) ~[worldedit-bukkit-7.0.0-beta-05.jar:?]

at com.sk89q.worldedit.internal.registry.AbstractFactory.parseFromInput(AbstractFactory.java:69) ~[worldedit-bukkit-7.0.0-beta-05.jar:?]

at com.sk89q.worldedit.world.registry.LegacyMapper.loadFromResource(LegacyMapper.java:91) ~[worldedit-bukkit-7.0.0-beta-05.jar:?]

at com.sk89q.worldedit.world.registry.LegacyMapper.<init>(LegacyMapper.java:61) [worldedit-bukkit-7.0.0-beta-05.jar:?]

at com.sk89q.worldedit.world.registry.LegacyMapper.getInstance(LegacyMapper.java:153) [worldedit-bukkit-7.0.0-beta-05.jar:?]

at com.sk89q.worldedit.WorldEdit.loadMappings(WorldEdit.java:335) [worldedit-bukkit-7.0.0-beta-05.jar:?]

at com.sk89q.worldedit.bukkit.WorldEditPlugin.onEnable(WorldEditPlugin.java:91) [worldedit-bukkit-7.0.0-beta-05.jar:?]

at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:332) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:404) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugin(CraftServer.java:342) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at org.bukkit.craftbukkit.v1_8_R3.CraftServer.enablePlugins(CraftServer.java:314) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at net.minecraft.server.v1_8_R3.MinecraftServer.s(MinecraftServer.java:406) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at net.minecraft.server.v1_8_R3.MinecraftServer.k(MinecraftServer.java:370) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at net.minecraft.server.v1_8_R3.MinecraftServer.a(MinecraftServer.java:325) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:235) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:504) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at java.lang.Thread.run(Thread.java:813) [?:1.8.0_192]

[ERROR] Error occurred while enabling WorldEdit v7.0.0-beta-05;6bbf29b (Is it up to date?)

java.lang.NoClassDefFoundError: com.sk89q.worldedit.world.block.BlockTypes (initialization failure)

at java.lang.J9VMInternals.initializationAlreadyFailed(J9VMInternals.java:96) ~[?:1.8.0_192]

at com.sk89q.worldedit.LocalConfiguration.<clinit>(LocalConfiguration.java:37) ~[?:?]

at com.sk89q.worldedit.bukkit.WorldEditPlugin.loadConfig(WorldEditPlugin.java:115) ~[?:?]

at com.sk89q.worldedit.bukkit.WorldEditPlugin.onEnable(WorldEditPlugin.java:93) ~[?:?]

at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:332) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:404) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugin(CraftServer.java:342) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at org.bukkit.craftbukkit.v1_8_R3.CraftServer.enablePlugins(CraftServer.java:314) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at net.minecraft.server.v1_8_R3.MinecraftServer.s(MinecraftServer.java:406) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at net.minecraft.server.v1_8_R3.MinecraftServer.k(MinecraftServer.java:370) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at net.minecraft.server.v1_8_R3.MinecraftServer.a(MinecraftServer.java:325) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:235) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:504) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at java.lang.Thread.run(Thread.java:813) [?:1.8.0_192]

Caused by: java.lang.NoSuchMethodError: com/google/common/base/Preconditions.checkState(ZLjava/lang/String;Ljava/lang/Object;Ljava/lang/Object;)V (loaded from file:/pro/bin/mc/craftbukkit/1.8.8/craftbukkit-1.8.8.jar by sun.misc.Launcher$AppClassLoader@a2dbda9) called from class com.sk89q.worldedit.registry.Registry (loaded from file:/home/gs-40475/plugins/worldedit-bukkit-7.0.0-beta-05.jar by org.bukkit.plugin.java.PluginClassLoader@5912dcce).

at com.sk89q.worldedit.registry.Registry.register(Registry.java:51) ~[?:?]

at com.sk89q.worldedit.registry.NamespacedRegistry.register(NamespacedRegistry.java:47) ~[?:?]

at com.sk89q.worldedit.world.block.BlockTypes.register(BlockTypes.java:644) ~[?:?]

at com.sk89q.worldedit.world.block.BlockTypes.register(BlockTypes.java:640) ~[?:?]

at com.sk89q.worldedit.world.block.BlockTypes.<clinit>(BlockTypes.java:33) ~[?:?]

at com.sk89q.worldedit.extension.factory.parser.DefaultBlockParser.parseLogic(DefaultBlockParser.java:261) ~[?:?]

at com.sk89q.worldedit.extension.factory.parser.DefaultBlockParser.parseFromInput(DefaultBlockParser.java:82) ~[?:?]

at com.sk89q.worldedit.extension.factory.parser.DefaultBlockParser.parseFromInput(DefaultBlockParser.java:55) ~[?:?]

at com.sk89q.worldedit.internal.registry.AbstractFactory.parseFromInput(AbstractFactory.java:69) ~[?:?]

at com.sk89q.worldedit.world.registry.LegacyMapper.loadFromResource(LegacyMapper.java:91) ~[?:?]

at com.sk89q.worldedit.world.registry.LegacyMapper.<init>(LegacyMapper.java:61) ~[?:?]

at com.sk89q.worldedit.world.registry.LegacyMapper.getInstance(LegacyMapper.java:153) ~[?:?]

at com.sk89q.worldedit.WorldEdit.loadMappings(WorldEdit.java:335) ~[?:?]

at com.sk89q.worldedit.bukkit.WorldEditPlugin.onEnable(WorldEditPlugin.java:91) ~[?:?]

... 11 more
Aiuti su come risolvere?
Grazie in anticipo

-zSharpFire
[Immagine: GunMaker%20Addicted!.png][Immagine: Server%20in%20building!.png][Immagine: Pluginner%20Addicted.png]
13/03/2019, 16:06zSharpFIre ha scritto: Aiuti su come risolvere?

Prova ad installare FAWE, ossia Fast Async World Edit (da qui: https://empcraft.com/fawe/download/?bukkit )
Differenze? Più leggero, aggiornato e hai più comandi (Modificato 13/03/2019, 16:29 da cla7997.)
This text is hard to read if you play the game at the default resolution, but at 1080p it's fine!
[Immagine: 2Yp7lHe.gif]
forum fò·rum/
sostantivo maschile
Servizio Internet che permette di inviare e leggere messaggi su un argomento specifico, che restano a disposizione per i commenti altrui.
Devo anche spiegarti perché non funziona o lo capisci da solo leggendo la descrizione del plugin che hai scaricato?

Citazione:This version is compatible with:
  • Spigot for 1.13+ (Paper recommended)

  • THIS VERSION IS NOT COMPATIBLE WITH VERSIONS PRIOR TO 1.13

Magari preferiresti usare la versione 6.1.9.

@cla7997 Ti rendi conto che FAWE è un Fork di WorldEdit e ti scaricherà automaticamente WorldEdit nel server?
Se ti sono stato d'aiuto, mi offriresti una birra?
[Immagine: MnksU9y.png]

Rip Maxcraft
13/03/2019, 20:10Maxetto ha scritto: @cla7997 Ti rendi conto che FAWE è un Fork di WorldEdit e ti scaricherà automaticamente WorldEdit nel server?

Ma va? Genio
This text is hard to read if you play the game at the default resolution, but at 1080p it's fine!
[Immagine: 2Yp7lHe.gif]
forum fò·rum/
sostantivo maschile
Servizio Internet che permette di inviare e leggere messaggi su un argomento specifico, che restano a disposizione per i commenti altrui.
13/03/2019, 20:10Maxetto ha scritto: Devo anche spiegarti perché non funziona o lo capisci da solo leggendo la descrizione del plugin che hai scaricato?

Citazione:This version is compatible with:
  • Spigot for 1.13+ (Paper recommended)

  • THIS VERSION IS NOT COMPATIBLE WITH VERSIONS PRIOR TO 1.13

Magari preferiresti usare la versione 6.1.9.

@cla7997 Ti rendi conto che FAWE è un Fork di WorldEdit e ti scaricherà automaticamente WorldEdit nel server?
"grazie" ho risolto, potete chiudere
[Immagine: GunMaker%20Addicted!.png][Immagine: Server%20in%20building!.png][Immagine: Pluginner%20Addicted.png]
Discussioni simili
Risposta di xPivanux
17/03/2019, 01:29
Risposta di BlueDanger
09/11/2018, 21:41
Risposta di zGianmarcoMG
03/11/2018, 22:53
 
[Problema] World Guard
Risposta di Wimowa
16/06/2018, 12:11
 
[Problema] World Guard
Risposta di Settez
03/06/2018, 07:23

Utente(i) che stanno guardando questa discussione: 2 Ospite(i)